0

I recently bought a new MacBook Pro Retina and unfortunately the built-in VPN client (Cisco IPsec configuration) doesn't work. Whats interesting third party VPN Tracker 8 works.

I'm running Mac OS X is Yosemite 10.10.3.

Logs after getting connected status using Apple build-in client:

May 17 21:31:44 MacBook-Pro-Marcin.local racoon[706]: IKE Packet: transmit success. (Information message).
May 17 21:31:44 MacBook-Pro-Marcin.local racoon[706]: IKEv1 Information-Notice: transmit success. (R-U-THERE? ACK).
May 17 21:31:44 MacBook-Pro-Marcin.local racoon[706]: IKE Packet: receive success. (Information message).
May 17 21:32:14 MacBook-Pro-Marcin.local racoon[706]: IKE Packet: transmit success. (Information message).
May 17 21:32:14 MacBook-Pro-Marcin.local racoon[706]: IKEv1 Information-Notice: transmit success. (R-U-THERE? ACK).
May 17 21:32:14 MacBook-Pro-Marcin.local racoon[706]: IKE Packet: receive success. (Information message).
May 17 21:32:14 MacBook-Pro-Marcin.local racoon[706]: IPSec Phase 2 started (Initiated by me).
May 17 21:32:14 --- last message repeated 1 time ---
May 17 21:32:14 MacBook-Pro-Marcin.local racoon[706]: >>>>> phase change status = Phase 2 started
May 17 21:32:14 --- last message repeated 1 time ---
May 17 21:32:14 MacBook-Pro-Marcin.local racoon[706]: IKE Packet: transmit success. (Initiator, Quick-Mode message 1).
May 17 21:32:14 MacBook-Pro-Marcin.local racoon[706]: Fatal NO-PROPOSAL-CHOSEN notify messsage, Phase 1 should be deleted.
May 17 21:32:14 --- last message repeated 1 time ---
May 17 21:32:14 MacBook-Pro-Marcin.local racoon[706]: Message: ''.
May 17 21:32:14 --- last message repeated 1 time ---
May 17 21:32:14 MacBook-Pro-Marcin.local racoon[706]: IKE Packet: receive success. (Information message).
May 17 21:32:17 MacBook-Pro-Marcin.local racoon[706]: IKE Packet: transmit success. (Phase 2 Retransmit).
May 17 21:32:42 --- last message repeated 7 times ---
May 17 21:32:42 MacBook-Pro-Marcin.local racoon[706]: IKE Packet: transmit success. (Information message).
May 17 21:32:42 MacBook-Pro-Marcin.local racoon[706]: IKEv1 Information-Notice: transmit success. (R-U-THERE? ACK).

Both VPN Tracker 8 and Apple build-in VPN client have connected status enter image description here. However using the second one safari can't open the page because the server where the page is located isn't responding. My ifconfig logs to satisfy your request:

/* -ipconfig with VPN Tracker 8. VPN work great.
*
*
*
*/

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 ::1 prefixlen 128 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    nd6 options=1<PERFORMNUD>
gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 8192
    inet 192.168.43.64 --> 172.30.4.0 netmask 0xffffffff 
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether d0:a6:37:ee:7d:79 
    inet6 fe80::d2a6:37ff:feee:7d79%en0 prefixlen 64 scopeid 0x4 
    inet 192.168.0.100 netmask 0xffffff00 broadcast 192.168.0.255
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether 4a:00:00:44:18:c0 
    media: autoselect <full-duplex>
    status: inactive
en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether 4a:00:00:44:18:c1 
    media: autoselect <full-duplex>
    status: inactive
p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
    ether 02:a6:37:ee:7d:79 
    media: autoselect
    status: inactive
awdl0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1452
    ether e2:d2:f5:14:4f:8e 
    inet6 fe80::e0d2:f5ff:fe14:4f8e%awdl0 prefixlen 64 scopeid 0x8 
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
bridge0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    options=63<RXCSUM,TXCSUM,TSO4,TSO6>
    ether d2:a6:37:ee:ae:00 
    Configuration:
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
        maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x2
    member: en1 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 5 priority 0 path cost 0
    member: en2 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 6 priority 0 path cost 0
    nd6 options=1<PERFORMNUD>
    media: <unknown type>
    status: inactive

/* -ipconfig with Apple built-in VPN client. VPN does not work.
*
*
*
*/

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 ::1 prefixlen 128 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    nd6 options=1<PERFORMNUD>
gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether d0:a6:37:ee:7d:79 
    inet6 fe80::d2a6:37ff:feee:7d79%en0 prefixlen 64 scopeid 0x4 
    inet 192.168.0.100 netmask 0xffffff00 broadcast 192.168.0.255
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether 4a:00:00:44:18:c0 
    media: autoselect <full-duplex>
    status: inactive
en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether 4a:00:00:44:18:c1 
    media: autoselect <full-duplex>
    status: inactive
p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
    ether 02:a6:37:ee:7d:79 
    media: autoselect
    status: inactive
awdl0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1452
    ether e2:d2:f5:14:4f:8e 
    inet6 fe80::e0d2:f5ff:fe14:4f8e%awdl0 prefixlen 64 scopeid 0x8 
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
bridge0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    options=63<RXCSUM,TXCSUM,TSO4,TSO6>
    ether d2:a6:37:ee:ae:00 
    Configuration:
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
        maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x2
    member: en1 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 5 priority 0 path cost 0
    member: en2 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 6 priority 0 path cost 0
    nd6 options=1<PERFORMNUD>
    media: <unknown type>
    status: inactive
utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
    inet 192.168.43.120 --> 192.168.43.120 netmask 0xffffffff
  • 2
    The error message "NO-PROPOSAL-CHOSEN" during phase 2 tells that your client (Mac) and your IPsec server didn't find any agreeing encryption algorithm. Could you improve your question by indicating which "Encryption:" you choosed on building your Mac's network configuration? – daniel Azuelos May 19 '15 at 11:52
  • 2
    Your problem is between the Apple VPN client configuration and your IPsec server, not within your Wi-Fi and neither within VPN Tracker 8. Hence you could get a correct help by providing your Apple VPN client configuration. Could you also include what is the IPsec server you are connecting to? – daniel Azuelos May 20 '15 at 12:50
  • 2
    Since your question is about the Apple built-in VPN client, please include within your original question the screen capture of its configuration. – daniel Azuelos May 20 '15 at 16:56
  • 1
    Could you please put the useful information within your original question with the help of the edit button. The comments shouldn't be used to carry key details of the original question. – daniel Azuelos May 23 '15 at 8:39
  • 1
    You are having problems connecting to a server but you make no mention of that server in your question. What is the configuration on the server? What is the configuration on the client? – miken32 May 26 '15 at 3:35
1

Your problem might be a basic MacOS X network configuration one. Most probably if you are using the infamous Automatic network configuration.

So as to clarify this point could you please make two ifconfig -a.

  1. One when your working VPN is built with VPN Tracker 8.
  2. One after your VPN failed with the Apple client configured for a Cisco IPSEC kind of VPN: VPN Cisco step 1

Then check that you place your newly created VPN interface on the top of the set of interfaces configured so as to maintain the use of the tunnel as long as it is up: VPN Cisco stop 2.1

  • I have to clarify one thing. Both VPN Tracker 8 and Apple build-in VPN client have connected status ( app.box.com/s/jy6so8cvzh4cmu0r6h49657xow3xblhj ). However using the second one safari can't open the page because the server where the page is located isn't responding. My ifconfig logs to satisfy your request pastebin.com/ZvHn4a7F . – Marcin Charęziński May 24 '15 at 10:11
  • This clarification is pretty usefull and may avoid any other reader to give you irrelevant advice. I suggest you to add this key detail within your original question. Comments are there just to comment and their fate is the trash. – daniel Azuelos May 25 '15 at 23:56
  • Didnt help. Sorry. – Marcin Charęziński May 26 '15 at 16:08
  • I think you didn't notice 2 key points in my proposed answer : 1. you are using the Automatic configuration which isn't suited for people who want to understand and fix connection problems, 2. your interfaces are in the wrong order to achieve the use of your VPN interface first. – daniel Azuelos Aug 18 '15 at 6:47
-1

I found solution. It's working now.

I changed my DNS settings to use Google Public DNS in VPN(IPSec) preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .