1

I don't know how it happened, but one of my full screen apps, when launched for the first time, opened on my secondary display. Now no matter what I try, the app always launches on this secondary display.

How can I tell this app, to use primary display?

I use two displays, one horizontal (primary), one vertical (secondary). I tried assigning the app to particular desktop, but this does not help because the app window remains vertical on my horizontal display.

[Update]

I managed to drop the app into windowed mode after it launched. Then I moved the window to the primary display and maximized it again. It worked fine, however when I quit and launch the app again it starts full screen on my secondary display.

Is it possible that it's the app itself that chooses the secondary display instead of primary for full screen work? That wouldn't make much sense.

  • Did you try taking it out of fullscreen, dragging to the other widow, enabling fullscreen again? Also, do you have Displays have separate Spaces enabled in prefs > Mission Control? – Tetsujin May 18 '15 at 9:51
  • @Tetsujin this app does not have windowed mode. However when I use Mission Control to see all windows and desktops, I can see that there is a small black widow "behind". I can drag it to another desktop but it does not help. Also, yes Displays have separate spaces is enabled. – SiliconMind May 18 '15 at 9:55
  • sorry, I've never used an app with no windowed mode; no idea where to start – Tetsujin May 18 '15 at 10:22

You must log in to answer this question.

Browse other questions tagged .