0

Briefly my Mac Pro (4,1 Early 2009 ) stopped booting which I eventually traced to the plastic clip holding the north bridge down failing. Seems to be a common issue.

Replaced the clips and now it will boot again and is stable but refuses to run the 2nd CPU. Kernel boot messages show it's there but disabled.

Apple hardware test gives error of 4SNS/1/40000000: TCBC-252:000 which from various sites on the net I understand to mean

4SNS - Sensor
TCBC
|----- Temperature
 |---- CPU
  |--- CPU B ?
   |-- C ?`

Any idea on the numbers ?

Can anyone help me diagnose here, is it new Heatsink time or new Logic board time. Neither is great but a heatsink is much cheaper than a logic board.Is it something else that's fixable ?

  • Both CPUs verified good in socket A.
  • All RAM verified good in Socket A RAM slots.
  • No diagnostic LEDs lit.
  • New thermal paste everywhere
  • SMC reset
  • PRAM reset

EDIT: RAM Clarification EDIT: Things done Thanks

  • reset SMC already? [idk the numbers, sorry.] If the clip failed, it might have fried something. New paste everywhere? (wow, that was stream of consciousness, sorry) – Tetsujin May 17 '15 at 17:33
  • @tetsujin Tried all that. Must have redone the CPUs and paste 5 times by now. As they work in either socket at least I know they're ok. My theory is I damaged the CPU board or heatsink whilst replacing the thermal paste somehow. So want to know what the code actually means. – Dean Smith May 17 '15 at 17:55
1

I rang Apple in the end, they didn't know either without seeing it. 8-)

Suggested I take it in for a free diagnosis.

Before I did that I tried taking the heatsink sensors connected off and replacing it.

Bingo, all fixed.

So the answer must be that this error is the heatsink sensor.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .