1

I just updated to the new Photos app on OS X and let it go through the process of importing my iPhoto library and uploading to iCloud. But it looks like about half of the library won't upload. It seemed to claim that it worked, but looking at iCloud.com shows that only about half of them are there. The iPhoto events were successfully converted to albums, but many of them are empty.

I went into the Photos settings and un-ckecked and re-checked the iCloud option, and saw this:

enter image description here

So I highlighted the whole library (command-A) and selected the "Consolidate" option. It took a while of course, but seemed to do the trick. It then went about re-uploading to iCloud.

After allowing that to finish, it appears that the problem persists. And performing the same steps in the settings results in the same message above.

The Photos Library in Finder is about the same size as the iPhoto Library, so I suspect it has all of the files. When I "Show Package Contents" all of the files appear to be there. And I definitely have enough space in iCloud.

Is there something else I can try?

Update

While "consolidating" again I was presented with this error:

enter image description here

Clicking "OK" brought up a file browser dialog. I selected the home directory folder as instructed, and then was shown an error saying that it couldn't find the original file (a .jpg) in that folder. Well, sure, the files are organized in sub-folders in the iPhoto library. Isn't that where it would look for them?

  • @Buscar웃: There's a limit? I must have missed it... – David May 16 '15 at 21:12
  • @Buscar웃: Yes, plenty. I have 200GB of storage. Photos consume approximately 37 GB (about half my Photos library size), a few more GB are used by other things, the rest is unused. – David May 16 '15 at 21:19
  • @Buscar웃: Well, I selected all photos and chose "Consolidate". Then it claimed to be "consolidating" about half of the library for a while. Is there something else that needs to be done? – David May 16 '15 at 21:33
  • @Buscar웃: I guess I'm not sure what that means. The files aren't sum links or anything, they seem to be correct on the file system inside the Photos Library package. I also just found another symptom of the problem, I've updated the question accordingly. It seems like it thinks it can't find these files, but it most certainly can. – David May 16 '15 at 21:48
1

Options 3,4 was the only ones that worked for me, but no guarantees...

  1. Holding Opt+Cmd while opening Photos, to do a "Repair".
  2. Selecting to keep originals on the computer, not optimize" them.
  3. Carefully wipe what you have and start again. This should include deleting "Events" folders in iCloud.com>Photos, before swapping libraries on the computer, to avoid orphaning them. See below...
  4. Use "iPhoto Library Manager" to "Rebuild" the original iPhoto Library, then re-migrate. This assumes you have backup of an "un-migrated" version, in Time Machine or elsewhere. I had a folder with 1.6Gb of iPod thumbs in my original library. Also, I think it may update the Last Modified" date to help the upload. I'm not sure why it worked..

How do I delete Unlinked folders

iPhoto Library Manager

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .