1

My safari refuses to let me install any extension. All installations ended up with a message:

Safari can't install this extension
An error occurred while installing the extension <extension name>.

I have tried at least 2 dozens of unrelated extensions from safari extension page. Restart safari many times. Nothing works!

What can I do? Can I reinstall Safari? If I reinstall Safari, how do i ensure the passwords that are saved by Safari are not lost?

I am using OS X Yosemite 10.10.3 on rMBP 15″ 2014 model.

  • I'd start with the basics - Disk Utility, fix permissions & repair drive. Reinstall 10.10.3 from the combo updater Let us know how it goes... – Tetsujin May 16 '15 at 9:24
  • Done the fix permission and drive repair - there are some permissions fixed and drive is perfectly ok. Also tried to reinstall 10.10.3 from the link but got a page not found error. So far still the same, can't install any extension. – Thomas May 16 '15 at 15:54
  • my bad - I tried to clean the 'nationality' from the link & failed :( try support.apple.com/kb/DL1804? – Tetsujin May 16 '15 at 16:09
  • Sorry, it doesn't work after I install the OSXUpdCombo10.3.3. Still have the same problem. – Thomas May 22 '15 at 14:21
  • I reinstall OS X from the recovery and it is still not working. I really hate to reinstall the whole MBP from scratch up... – Thomas May 23 '15 at 1:45

You must log in to answer this question.

Browse other questions tagged .