3

After upgrading OSX to Yosemite and Skype to 7.7 (335), Skype gets stuck on "Signing in..." when starting.

It does sign in, as Contacts > Add Contact forces the main window to open, but "Signing in..." never goes away.

Already tried, but didn't work:

  • Signing out, quitting ("Signing in..." stays even when signed out), then signing back in.

  • Everything on the Skype support page for Why can't I sign in to Skype for Mac OS X?.

  • Removing ~/Library/Application Support/Skype.

  • Reinstalling Skype

I'm using my Microsoft ID to sign in.

Any clues?


Following the @Buscar advice I used nettop in terminal to monitor Skype connections.

After quitting Skype, I see 3 connections still there about 20 seconds after quitting. Two of them use port 443 (status LastAck and FinWait1), the other is on a high port (12k+), status FinWait1. Last one to go away is to blu403-m.hotmail.com:443 with status FinWait1.

0

3 Answers 3

2

The following procedure seems to have solved the problem:

  1. Sign out from Skype
  2. Quit Skype and wait until all connections listed in nettop are cleared
  3. Open Skype
  4. Choose "Sign in with a different account" from the Microsoft ID login screen.
  5. Try to sign in with Skype Name (but fail, since I can't do that anymore after I linked my Skype account to my MS account).
  6. Go back and sign in with my Microsoft ID.

The "Signing in..." window was displayed for a few seconds, then the home window opened normally. Problem solved. I'm guessing steps 4-6 solved the issue, but I have no idea why.

1
  • That is good enough for me a +
    – Ruskes
    May 15, 2015 at 22:05
2

At some point skype on my office mac was unable to connect. After trying all the mentioned solutions (update, re-install, delete all preferences files) the problem was still there. On other PC/Mac/Phone I was able to connect.

After some investigation I found that on my office mac I had a public IP address and a secondary private IP address (non routable; like 10.xx.xx.xx) for internal use. Looking at the skype network activity I discovered it used both address.

After disabling the private address it started to work again.

Beware: if you are connected to internet through a modem router (wifi or cabled) your router is doing NAT and so you have a private address that is routed to the public network and so your case is different from mine.

PS Solved the connection problem, if I re-enable the private address, skype is able to work and even to login. Really a nice piece of software!

2
  • ifconfig to show the IP addresses that you have, then something like sudo ifconfig en0 delete 10.0.0.1 to delete the one that is wrong. I had a bad address from a previous VPN connection, and as soon as I deleted it, Skype could connect again. Jul 28, 2016 at 17:24
  • Voting this answer up. I had the same problem and I fixed it by disabling a secondary IP address I had on the same network interface. On OSX it's called Virtual Interface. After that Skype could log in normally Aug 10, 2016 at 20:07
0
  1. Kill Skype
  2. Open ~/Library/Application Support/Microsoft folder
  3. Move Skype for Desktop folder to trash
  4. Restart Skype

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .