4

I want to install java based "lp_solve" LP solver on my MacBook Air, OS X Yosemite. I tried to follow the instructions given here. But when I run sh ccc.osx, it is not creating the liblpsolve55.dylib and liblpsolve55.dylib. I need help installing this solver. Or maybe suggest me a similar solver which is easy to install on OS X Yosemite.

  • Thanks for the edit. I will take care of the links from next time. – user1105 Jun 11 '15 at 15:04
3

The easiest way is doing it using homebrew. You just need to type the following couple of commands in a terminal window:

brew tap brewsci/science
brew install lp_solve

If you don't have homebrew installed, just type the following to install before the previous commands:

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
  • Thanks a lot, this thing successfully installed the LP solver. I will use the LP solver and confirm whether it works fine or not. – user1105 Jun 11 '15 at 15:24
  • Do you know how to get this lp_solve working in Python or R? I got some lpsolve already working for R but not for Python. – hhh Jun 5 '17 at 15:40
  • 1
    homebrew/science is deprecated and brewsci/science should be used instead. – Kun Ren May 7 '18 at 1:25
  • Could also use: brew install brewsci/science/lp_solve – spencer.sm Apr 12 '19 at 5:26
1

What's your problem in specific? Any error messages?

I just tried to compile it and I didn't run into any problem:

$ cd lpsolve55/
$ sh ccc.osx
$ ls  bin/osx64/
liblpsolve55.a     liblpsolve55.dylib
  • I tried to do exactly this, but I cannot see the liblpsolve55.a & liblpsolve55.dylib files. – user1105 Jun 11 '15 at 15:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .