4

I use Yosemite with Chrome version 42.0.2311.135 (64-bit). When writing in a text area the spell checker correctly detects English and French, but does not detect Spanish, and so it marks as wrong correctly written Spanish words:

img

I don't know why it happens. English, French and Spanish are set in Chrome:

img

and also in the Mac preferences:

img

Is there any setting to have Chrome/MacOS detect Spanish like it does for French and English?

8
  • It must be the Chrome, since it works purfectly in FireFox "Que tal usted"
    – Ruskes
    May 15 '15 at 1:43
  • Just tested in Firefox, I have the exact same issue.
    – Florent2
    May 15 '15 at 15:03
  • hmmm... if you right click on the misspelled word and select the Spanish it works or not ?
    – Ruskes
    May 15 '15 at 16:29
  • OS X Language and region settings don't have anything to do with spellcheck as far as I know. Nor do Chrome's Language settings. May 15 '15 at 17:22
  • Buscar: on Firefox it works now that I have installed the Spanish dictionary.
    – Florent2
    May 15 '15 at 22:18
3

I do not use Chrome (often) and Firefox is my favorite browser.

So I added Spanish to the Spell check and if I right click and select it it works just fine.

Spanish

One drawback is it applies to the whole text so I can not spell check just a single word.

If you want to do that in Chrome:

Under the Edit tab select the Spelling and Grammar-> Show

spelling

Now select Spanish

Spanish

2
  • 3
    He asked for Chrome, not Firefox
    – andrewmh20
    May 15 '15 at 18:46
  • 2
    I recommend you delete the irrelevant Firefox stuff in your answer to a question about Chrome. May 15 '15 at 23:53
2

The place where you set spell check is System Preferences/Keyboard/Text/Spelling. Go to the Setup item there and check the boxes for all three languages you want, and then set it to Automatic. Automatic doesn't always work perfectly, however. Below is the result I get with just boxes for English, French, and Spanish checked and set to Automatic.

enter image description here

7
  • Tom where is the Spelling you mentioned? I don't see it in System Preferences/Keyboard (monosnap.com/image/aiOtsmB25Tn51osTzGddaVnUCfuNwK) and no way to check boxes for languages.
    – Florent2
    May 15 '15 at 22:16
  • It still does not work, I have several languages selected (monosnap.com/image/zQf8MUqBQ1bqmh3KC3S3914adOaVMg, monosnap.com/image/Ly2ziRmEYLt3xjrI9YzHx7a49YcJAV) and Spanish is still not detected, Spanish words are still underlined in red. Thanks for you help Tom.
    – Florent2
    May 16 '15 at 0:09
  • thanks, I've unchecked all but English, French and Spanish and still have the same issue.
    – Florent2
    May 17 '15 at 13:21
  • @Florent2 Strange that it works for me but not for you. I notice your Chrome is not up to date (should be 152 at the end), but doubt that matters. May 17 '15 at 18:59
  • 1
    This should be the correct answer. Apparently Chrome more or less uses the built-in spellchecking of MacOS, and you'll have to set it to automatic so it works for all languages.
    – xji
    Apr 5 '17 at 19:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .