1

I have to say first, I have almost zero experience is the use of Terminal, an usually I'm very careful with what command I use.

I have tryed to create a bootable Android x86 usb and it was a success, it booted perfectly on a windows pc. I hope it worked on Mac too, sadly it was not.

But I immidiatly(usually shut the Mac once a week) discovered, by that boot try, I did something wrong. A slow grey loading bar appeared at the start up! Before realizing the bootable android usb (with UNetbooting) I tryed a terminal operation I saw on youtube and in another thread

sudo DiskUtil UnmountDisk disk1s1
sudo dd if=/Users/Me/Desktop/android.iso of=/rdisk1s1 

(I get now it was correct of=/dev/rdisk, right?)and I use it three times, without any results, I thought.So, after the long slow bar, I tryed to verify disk with Disk Utility and found I need to repair.

Booted my install CD and before I opened Disk Utility notice in the choice of partition install Macintosh HD was not appearing, just my Vista partition.

Disk Utility sadly sad me it was beyond repair and needed a backup. I did it twice, one with SuperDuper! (who was even faster than Time Machine, who started even long before I downloaded SD!). But I'm not ok with this. I find here this

df -hl

and

sudo fsck_hfs -l /dev/disk0s2

with, again, just the repair advaice.

Even noticed the three tries were placed at Macintosh HD folder with lost+found and DamagedFiles folders, all created at the same time.

So I hoped deleting them the problem could be solved. No, it isn't.

Still I transcripted the 2 damaged files in the folder who are

.DSIsRunning            Macintosh HD/Library/Prefences/DirectoryService


utmpx                   Macintosh HD/private/var/run

Now. My only chance to set everything back, even if my Mac still works without any defect sign (expect the long startup), is just to restore backup or else?

4
  • considering what you are already doing in Terminal, call you self mature :) just a hint, anything that needs "sudo" review carefully.
    – Ruskes
    May 14, 2015 at 23:16
  • the only shell command i can really remember is ping 192.168.1.x , more than superuser i should use avarage (copypaster) user :D in the wrong command I follow the video yhat suggest the corret but showed the wrong one
    – tebkanlo
    May 14, 2015 at 23:38
  • well.......next time first take a look what is what before running any "sudo" in this case run the "diskutil list" to see all drives. In your case it was most probably the Apple_partition_scheme *13.6 MB disk1 and the 1: Apple_partition_map 32.3 KB disk1s1 that is now destroyed.
    – Ruskes
    May 15, 2015 at 0:01
  • I tried to search then in spotlight (if even it was possible). Can't find any of them, does it mean it is like you said? And what could I try to fix it?
    – tebkanlo
    May 15, 2015 at 9:07

1 Answer 1

1

Just me! Apparently choosing a password not as soon as possible assigned me another user (former user127893, now user128454) but still same username and almost similar avatar (a quarter or the former with a more visible Triforce :D )

BTW recently I tried to run a Disk permissions check and repair. After that I repeat the Verify Disk and the error message changed (if I remember well it wasn't like this) incorrect number of thread record.

Hope if I retry a repair this time I'll have some luck.

P.S.:I'm a bit surprised of this did't get much attention and I'm gonna search mmore about Buscar웃SD suggestion. I wonder if I need to apply Cunningham's Law (the best way to get the right answer on the Internet is not to ask a question, it's to post the wrong answer)

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .