0

I have the dreaded issue with recurring sync service processes wreaking havoc on my MacBook Pro with O S X 10.9 Mavericks and stealing my CPU cycles for no apparent good reason. Usually with a 3 month hiatus, strangely enough. It might run most of the times, but it doesn't interfere with heavy workloads in other apps, like music production software.

Could you please advice where and how to edit the SyncServices of OS X 10.9 Mavericks, so that all spawned sync processes like Mingler and iCalExternalSync are given really low priorities and/or are set to only run at certain time slots? I'm growing really tired of these processes that run even as I've inactivated most accounts, except for email. No Exchange servers to my knowledge are involved.

It would also be acceptable to just force these processes to not run when I don't need them running, so I can have my CPU back.

As Mingler belong to the SyncServer process and iCalExternalSync belongs to CalendarAgent I've identified likely setting files in com.apple.syncservices.SyncServer.plist and com.apple.CalendarAgentLauncher.plist both in /System/Library/LaunchAgents/, but I see no clear setting to make here in order to stop these processes from running all the time and use more CPU than they deserve. Most likely I need to find a good setting with the effect I want. What could a good setting be to try for this?

0

It's a bit of a workaround, but these unload commands seem to do the trick. I put them in a script that I run when I need more of my CPU:

#!/bin/bash
launchctl unload /System/Library/LaunchAgents/com.apple.AddressBook.SourceSync.plist
launchctl unload /System/Library/LaunchAgents/com.apple.CalendarAgent.plist
launchctl unload /System/Library/LaunchAgents/com.apple.syncdefaultsd.plist

For when processes are acceptable, replace "unload" with "load"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .