0

I'm running 10.10, and have a wireless mighty mouse. I want to turn off the right click on the mouse. I went to System Settings > Mouse, and set the "Right Click" function to "Primary Button" instead of Secondary. However, this has no effect, and the right click still functions as a right click. Why is this?

2

For my Magic Mouse, Setting the Secondary click option to "click on left side," simply makes it so that the "right click" (contextual) behavior is reversed. i.e. left-clicking brings up a menu, and right-clicking is a normal click. UNchecking the checkbox beside Secondary Click turns off the "right click" behavior altogether.

Sys Pref

| improve this answer | |
0

Logging out and back in solved the issue. Doesn't seem right that you should have to log out to apply changes to the mouse settings, but it worked.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .