I believe this is the best forum to ask this question.

This issue is with iOS Safari's "Add to Home Screen", and is particularly specific to Google Keep.

I added "Google Keep" to Home Screen through Safari, and after logging in with an email ID (user A), I figured that I needed to login with some other user (user B). Now, Google Keep doesn't have a logout link within the Google Keep interface. Clicking on the signed in user's email address, the "Home Screen app" opens up the Safari browser for further working on that link. In short, there is no way of logging out!

What I have already tried:

  • Tried deleting the "Home Screen app" and adding it back, fresh! Yet, it holds on to the previous cookie/session, and auto logs in with user A.
  • Tried clearing Safari cache and cookie data from iOS settings!
  • Tried combinations of the above two.
  • Even tried using ?v=2 at the end of the Google Keep URL (https://keep.google.com/?v=2) and adding that to the "Home Screen", but ... the same!!

Is there any way of doing this? Or do I have to manually dig down into the iOS file system and delete the relevant plist or whatever way it's holding this data in?! And if I have to do the latter, can anyone point out which FS file do I exactly need to tackle?

It's for the first time that I am frustrated with iOS, but blame also somewhat falls on Google for not giving a simple logout link in Google Keep (or not having a full-fledged app yet)!!

Please help!


1 Answer 1


1) Log in to accounts.google.com

2) Login

3) in the Google Dashboard, stop and clear that user


3a) revoke ALL safari sessions and or Safari enabled Devices presented.

4) reboot iDevice and freshly sign in to Gkeep

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .