1

When I turned on my mac this morning, the world logo flashed and then took ages to boot up and finally when my logon screen came up. An extremely long password started typing itself out. I deleted this and typed in the correct password (it is correct, been using it for five years) but it won't allow me access.

I've tried rebooting with
Cmd ⌘ S
Cmd ⌘ R
Cmd ⌘ Opt ⌥ PR
and whatever else I've seen on forums and nothing works.

It still takes me to the log in screen and types in the long password and shakes when I type in the correct one. Is there any other way to fix this? If not how do i reinstall the drive when everything i do still takes me to the log in screen?

  • Took me while to think of this possibility… try another keyboard; that one might have a stuck key. Pure guess, but somewhere to start. – Tetsujin May 14 '15 at 10:42
  • 1
    Adding on to @Tetsujin - does the very long password ever stop? If not, you're likely looking at a stuck key. Trying a different keyboard (and mouse) may get you past this. Also, watch when you're entering your own password - where is the cursor? I once had a keyboard with a stuck left-arrow key, so typing in the correct password didn't work, since the stuck left-arrow kept moving my cursor to the beginning of the line, turning "password" into "drowssap". – Kevin Matheny May 14 '15 at 13:11
  • ohhh. that's got to become my new password now… no-one would ever guess that ;-)) – Tetsujin May 14 '15 at 13:26
  • I've tried everything with another keyboard - USB one but it didn't stop it going from to the log in screen either. The long password does stop and the cursor moves when I type in the password. – Anna May 15 '15 at 6:32
  • I'd disconnect all external devices, just to test, even the keyboard & mouse. – Tetsujin May 15 '15 at 15:24

You must log in to answer this question.

Browse other questions tagged .