0

I use Homebrew on my testing server on OS X.
I have php56, autoconf, and mcrypt installed through homebrew.

I was successful doing this on a different Mac but I am not having any luck this time.

When I type:

brew install php56-mcrypt

like I did on the other mac, it says:

Already downloaded: /Library/Caches/Homebrew/php56-mcrypt-5.6.7 ==> /usr/local/opt/php56/bin/phpize
2015-05-13 14:19:26 -0700

/usr/local/opt/php56/bin/phpize

Despite it stating that is "already installed", when going into /usr/local/Cellar/ there is no folder called "php56-mcrypt" like it had on my other Mac.

I have not done anything abnormal that I am aware of. What can I do? Is re-installing the best option?

2

With recent changes in brew (deprecation of homebrew/php) you now install php with mcrypt with the following.

brew install php@5.6 -with-mcrypt=mcrypt

You may have to uninstall previous installs of php

0

You probably need to link it. There may have been an error when you installed it that prevented it from being linked at that time. For example, it would not have been able to be linked if another version of mcrypt was linked when the install was running.

brew link php56-mcrypt

If another version is already linked, then running this command will tell you which version is linked and how to unlink it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .