9

I installed TeamViewer Host (v. 10.0) for making remote connections back to my Mac. It loads on start up automatically, and there doesn’t seem to be a preference to disable that behavior*. TeamViewer also does not appear in the “Login Items” system preference pane. I only need TeamViewer periodically, so for performance and security, I’d rather run it manually.

I see three related processes in Activity Monitor: TeamViewer Host, TeamViewer_Desktop, and TeamViewer_Service. I don’t just want to stop the UI / menu item from showing on startup, I want to stop all of these from loading.

How can I disable them from running at login, and then how should I run them when I want them?

* The “Show Computers & Contacts on startup” preference under Advanced isn’t it.

  • Keep in mind that disabling the support applications from running at startup will impact the ability of TeamViewer to run at all. It may not be possible to reverse the changes without reinstalling TeamViewer. (I say this as someone who recently expended significant time getting TeamViewer off my system.) – tubedogg May 14 '15 at 2:06
13

It is in Preferences in V 10.0.43320 which I downloaded and installed yesterday.

Go to Preferences > General and there untick 'Start TeamViewer with System'.

  • Unfortunately this is not working for the current version of TeamViewer host because that is no longer an option in the preferences (the jerks). – Patrick Jul 31 '17 at 13:32
3

The TeamViewer Host app is :

TeamViewer Host is running as a system service and is used for 24/7 access to remote computers, including login/logout and remote reboot - optimized for server maintenance or home-office access.

So it is intended to be running 24/7.

But if you want to disable it:

Find it using the launchctl list in Terminal

To stop it use sudo launchctl remove label_of_program_to_remove

The label_of_program_to_remove is the one you found in the launchctl list.

That will stop the current session.

To stop it from coming back again next time you reboot, move the com.teamviewer files from either /Library/LaunchAgents/ or your ~/Library/LaunchAgents/ folder. Instead of removing them outright, you just move them out of the LaunchAgents to someplace else.

2

Building on Buscar’s answer, for OS X 10.10 Yosemite:

  • To disable: sudo launchctl disable system/com.teamviewer.service
  • To re-enable: sudo launchctl enable system/com.teamviewer.service, and restart.

It seems like launchctl is under active development by Apple, and has changed substantially in Yosemite (10.10). See man launchctl. They still offer ‘legacy' commands like remove, but caution, “subcommands from the previous implementation of launchd are generally available, though some may be unimplemented.”

  • the man page of launchctl in 10.10 and even 10.11 is identical with the linked content, which is for 10.9. – Raptor Jan 18 '16 at 2:28
  • @Raptor I see substantially different content. The 10.9 page is about 1,400 words and last revised 1 May, 2009, versus the 10.11 page at 3,900 words and last revised 1 October, 2014. – duozmo Jan 18 '16 at 4:37
1

A simpler alternative is to install the standard Team Viewer version, not the Host one. The standard version has the options you seek.

  • Unfortunately, this is not any solution to the problem mentioned. – Arefe Jan 3 '18 at 0:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .