8

When I go to send a text message on my Apple Watch, whether it be through Siri or the messages app, it always tries to send a text message (green) rather than a iMessage (blue). I have tried turning on and off iMessage, restarting my iPhone and Watch, unpaired and re-paired my watch, and setting it up again as new. My watch will appear to try to send a regular (green) text message through my phone, but will get stuck on "Sending..." even though the text actually gets sent. I can send iMessages just fine on my iPhone. The people in my contacts who I am messaging do have iPhones and their contacts are set up as having an iPhone.

sending text message on my Watch

And a little while later, my watch will say that the message failed to send, even though they were sent:

Watch failed to send text

As you can see below, texts from my Watch end up sent as regular text messages, while texts from my iPhone to the same person get sent as iMessages. In the end, how do I get my watch to send iMessages?

texting from my iPhone

Update

I had an Apple Store Genius appointment a while back to try and resolve this. At the time I was running the iOS 8.4 public beta and I was told to wait for final release of iOS 8.4 to fix my problem, as the Apple employee was also experiencing the same problem and was also on the beta. Now with the final release of iOS 8.4 out, I've updated and it still doesn't work. I'm also updated to Watch OS 1.0.1.

My Watch will also occasionally tell me that my iCloud password is "incorrect" and that I need to sign into iMessage/FaceTime again (my password isn't wrong, I've done this multiple times). Although it seems to only ask me this when the Watch dies or is manually restarted.

0

I had the same issue. I also had two step verification switched on. When I restart my apple watch my iPhone asks for the iCloud password.

What it really means is go to appleid.apple.com and log in and go password and security and generate an app specific password for "iMessage and FaceTime”. Put that in (including the dashes) when it asks for the iCloud password and hopefully it should work :-)

  • Thank you so much! I wish that Apple would of made it clear that you need to create an app-specific password for it to work properly. – ajkblue Jul 10 '15 at 16:23
1

Try toggling iMessage off and on again. I find that this fixes many iMessage problems especially after a system update.

  • I've tried toggling iMessage on and off multiple times with no change. After I turn it off and back on, my watch will say "Password failed" and asks me to sign in with my Apple ID to iMessage again. – ajkblue May 13 '15 at 4:25
  • 2
    Toggling it off and on again where? – Cory Klein Sep 9 '15 at 18:38
  • Turning off iMessage and turning it back on worked for me. – user149419 Sep 30 '15 at 21:35
0

This worked for me when I had the same problem of not being able to send messages from the Apple Watch.

Go to Settings → Messages → Send & Receive and make sure that 'Start new conversations' is set to your phone number, not e-mail.

  • Yup, the 'Start new conversations' setting was already set to my phone number. – ajkblue Jul 1 '15 at 15:34
0

I just reset the Watch holding down both side buttons until the Apple Logo appeared and it worked fine. In my case the messages were not getting sent in iMessage, just as SMS. The reset fixed the issue.

0

I signed into iCloud and fixed the problem.

0

I had to reset my watch and it finally started working again with sending messages by iMessage. I have iOS 9 and watchOS 1.0.1.

You must log in to answer this question.

protected by bmike Sep 30 '15 at 23:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .