4

Since two weeks I see an incrementation in odd, graphical rendering issues on my MacBook Pro (13-inch, Mid 2012). These issues include flickering, oddly shaped figures, graphical noise and other annoying stuff.

The graphical issues happen on both my LCD display and external display. The occurrence is mostly random, but tend to happen slightly more on my LCD display.

Example of graphical rendering issues Example of graphical rendering issues

I have the following graphics/displays (I used system_profiler SPDisplaysDataType for dump):

Graphics/Displays:

Intel HD Graphics 4000:

  Chipset Model: Intel HD Graphics 4000
  Type: GPU
  Bus: Built-In
  VRAM (Dynamic, Max): 1024 MB
  Vendor: Intel (0x8086)
  Device ID: 0x0166
  Revision ID: 0x0009
  Displays:
    Color LCD:
      Display Type: LCD
      Resolution: 1280 x 800
      Pixel Depth: 32-Bit Color (ARGB8888)
      Main Display: Yes
      Mirror: Off
      Online: Yes
      Built-In: Yes
    PLE2483H:
      Resolution: 1920 x 1080 @ 60 Hz
      Pixel Depth: 32-Bit Color (ARGB8888)
      Display Serial Number: 1127842305866
      Mirror: Off
      Online: Yes
      Rotation: Supported
      Connection Type: Analog VGA or Analog Over DVI-I
      Adapter Firmware Version: 0,00

I use an Mini-display port to VGA adapter for my external display.

I have the following specs:

  • Processor: 2,5 GHz Intel Core i5
  • Memory: 4GB 1600 MHz DDR3
  • Disk: Samsung 850 EVO 250GB SSD
  • OS: 10.10.3

What have I tried to find the issue?

- Reset my PRAM

- De-installed all unnecessary kernel extensions, but kept the following:

at.obdev.nke.LittleSnitch (4240)
com.globaldelight.driver.BoomDevice (1.3)
com.viscosityvpn.Viscosity.tap (1.0)
com.viscosityvpn.Viscosity.tun (1.0)

- Run both the normal and extended hardware test. No trouble found.

- Used Disk Utility to check for faults. Everything was OK.

- I also have a lot of Kernel Panics which have to with IOGraphicsFamily. Might these be coincidence or not related at all?

Backtrace of Kernel Panic:

  Kernel Extensions in backtrace:
     com.apple.iokit.IOAcceleratorFamily2(156.14)[BE7D765B-49C1-34F9-B75E-3EAF8A4062A3]@0xffffff7f8ea37000->0xffffff7f8eaa5fff
        dependency: com.apple.iokit.IOPCIFamily(2.9)[52E715FC-521D-3869-B2EA-5228FA4BEA34]@0xffffff7f8cf24000
        dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[82EAD591-67E3-39CB-A232-A8095CA30E92]@0xffffff7f8d984000
     com.apple.driver.AppleIntelHD4000Graphics(10.0.6)[51B5D3C1-1319-3470-877F-B988299234BF]@0xffffff7f8eab4000->0xffffff7f8eb0ffff
        dependency: com.apple.iokit.IOSurface(97.4)[A4AE35B7-0C17-38F2-AD0D-A4C4B40196FB]@0xffffff7f8d833000
        dependency: com.apple.iokit.IOPCIFamily(2.9)[52E715FC-521D-3869-B2EA-5228FA4BEA34]@0xffffff7f8cf24000
        dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[82EAD591-67E3-39CB-A232-A8095CA30E92]@0xffffff7f8d984000
        dependency: com.apple.iokit.IOAcceleratorFamily2(156.14)[BE7D765B-49C1-34F9-B75E-3EAF8A4062A3]@0xffffff7f8ea37000

What can I do to solve these issues?

These issues are quite annoying. Does this mean my graphical card is dying (and I am unlucky), or is this a known issue and, hopefully, a workaround?

EtreCheck results

EtreCheck version: 2.2 (132)
Report generated 5/12/15, 10:19 PM
Download EtreCheck from http://etresoft.com/etrecheck

Click the [Click for support] links for help with non-Apple products.
Click the [Click for details] links for more information about that line.

Hardware Information: ℹ️
    MacBook Pro (13-inch, Mid 2012) (Technical Specifications)
    MacBook Pro - model: MacBookPro9,2
    1 2.5 GHz Intel Core i5 CPU: 2-core
    4 GB RAM Upgradeable
        BANK 0/DIMM0
            2 GB DDR3 1600 MHz ok
        BANK 1/DIMM0
            2 GB DDR3 1600 MHz ok
    Bluetooth: Good - Handoff/Airdrop2 supported
    Wireless:  en1: 802.11 a/b/g/n
    Battery: Health = Normal - Cycle count = 294 - SN = W03304Q01D3BB

Video Information: ℹ️
    Intel HD Graphics 4000
        Color LCD 1280 x 800

System Software: ℹ️
    OS X 10.10.3 (14D136) - Time since boot: 0:10:42

Disk Information: ℹ️
    Samsung SSD 850 EVO 250GB disk0 : (250,06 GB)
        EFI (disk0s1) <not mounted> : 210 MB 
        Recovery HD (disk0s3) <not mounted>  [Recovery]: 650 MB 
        BOOTCAMP (disk0s4) <not mounted> : 50.00 GB 
        MacBook SSD (disk1) / : 198.83 GB (119.04 GB free)
            Core Storage: disk0s2 199.20 GB Online

    MATSHITADVD-R   UJ-8A8  

USB Information: ℹ️
    Apple, Inc. Keyboard Hub 
        Logitech Gaming Mouse G302 
        Apple Inc. Apple Keyboard 
    Apple Inc. FaceTime HD Camera (Built-in) 
    Apple Inc. BRCM20702 Hub 
        Apple Inc. Bluetooth USB Host Controller 
    Apple Computer, Inc. IR Receiver 
    Apple Inc. Apple Internal Keyboard / Trackpad 

Thunderbolt Information: ℹ️
    Apple Inc. thunderbolt_bus

Configuration files: ℹ️
    /etc/hosts - Count: 1

Gatekeeper: ℹ️
    Anywhere

Kernel Extensions: ℹ️
        /Library/Application Support/Viscosity
    [not loaded]    com.viscosityvpn.Viscosity.tap (1.0) [Click for support]
    [not loaded]    com.viscosityvpn.Viscosity.tun (1.0) [Click for support]

        /Library/Extensions
    [not loaded]    at.obdev.nke.LittleSnitch (4240 - SDK 10.8) [Click for support]
    [not loaded]    com.globaldelight.driver.BoomDevice (1.3 - SDK 10.9) [Click for support]

Problem System Launch Daemons: ℹ️
    [failed]    com.apple.watchdogd.plist [Click for details]

Launch Agents: ℹ️
    [not loaded]    at.obdev.LittleSnitchUIAgent.plist [Click for support]
    [not loaded]    com.oracle.java.Java-Updater.plist [Click for support]
    [not loaded]    com.teamviewer.teamviewer.plist [Click for support]
    [not loaded]    com.teamviewer.teamviewer_desktop.plist [Click for support]

Launch Daemons: ℹ️
    [not loaded]    at.obdev.littlesnitchd.plist [Click for support]
    [not loaded]    com.microsoft.office.licensing.helper.plist [Click for support]
    [not loaded]    com.oracle.java.Helper-Tool.plist [Click for support]
    [not loaded]    com.sparklabs.ViscosityHelper.plist [Click for support]
    [not loaded]    com.teamviewer.Helper.plist [Click for support]
    [not loaded]    com.teamviewer.teamviewer_service.plist [Click for support]

User Launch Agents: ℹ️
    [not loaded]    com.google.keystone.agent.plist [Click for support]
    [not loaded]    com.spotify.webhelper.plist [Click for support]
    [not loaded]    com.vladalexa.MagicPrefs.plist [Click for support]

User Login Items: ℹ️
    iTunesHelper    Application  (/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)
    Dropbox    Application  (/Applications/Dropbox.app)
    Boom    Application  (/Applications/Boom.app)
    Growl    Application  (/Applications/Growl.app)
    Viscosity    Application  (/Applications/Viscosity.app)
    Spotify    Application Hidden (/Applications/Spotify.app)

Internet Plug-ins: ℹ️
    Silverlight: Version: 5.1.30514.0 - SDK 10.6 [Click for support]
    QuickTime Plugin: Version: 7.7.3
    JavaAppletPlugin: Version: Java 7 Update 79 Check version
    Default Browser: Version: 600 - SDK 10.10

3rd Party Preference Panes: ℹ️
    Java  [Click for support]
    MagicPrefs  [Click for support]

Top Processes by CPU: ℹ️
         3%    WindowServer
         2%    fontd
         0%    taskgated
         0%    notifyd
         0%    launchd

Top Processes by Memory: ℹ️
    403 MB    kernel_task
    287 MB    firefox
    86 MB    Finder
    82 MB    Spotlight
    66 MB    WindowServer

Virtual Memory Information: ℹ️
    289 MB    Free RAM 
    3.72 GB    Used RAM 
    37 MB    Swap Used 

Diagnostics Information: ℹ️
    May 12, 2015, 10:07:40 PM    Self test - passed
    May 12, 2015, 09:55:43 AM    /Library/Logs/DiagnosticReports/firefox_2015-05-12-095543_[redacted].hang
    May 11, 2015, 01:30:32 PM    /Users/[redacted]/Library/Logs/DiagnosticReports/askpermissiond_2015-05-11-133032_[redacted].crash
    May 9, 2015, 07:17:59 AM    /Library/Logs/DiagnosticReports/Kernel_2015-05-09-071759_[redacted].panic [Click for details]
    May 7, 2015, 06:19:45 PM    /Library/Logs/DiagnosticReports/Kernel_2015-05-07-181945_[redacted].panic [Click for details]
    May 5, 2015, 02:34:14 PM    /Library/Logs/DiagnosticReports/Kernel_2015-05-05-143414_[redacted].panic [Click for details]
    May 2, 2015, 04:41:02 PM    /Library/Logs/DiagnosticReports/Kernel_2015-05-02-164102_[redacted].panic [Click for details]
    Apr 24, 2015, 09:09:34 PM    /Library/Logs/DiagnosticReports/Kernel_2015-04-24-210934_[redacted].panic [Click for details]
    Apr 23, 2015, 09:51:30 PM    /Library/Logs/DiagnosticReports/Kernel_2015-04-23-215130_[redacted].panic [Click for details]
  • 2 questions. does it work in safe mode? did you do the Apple Hardware test ? and that is on the LCD display, or is it the external display or both – Ruskes May 12 '15 at 20:04
  • Haven't tried in safe mode, will do that now. And yes, I did the Apple Hardware test four days ago: nothing was found. I will try these again and keep you posted. Thanks so far! – Pepijn van Leeuwen May 12 '15 at 20:06
  • There is nice non-invasive app that does system profile and more - get it from here and try it. etresoft.com/etrecheck – Ruskes May 12 '15 at 20:13
  • @Buscar웃 I am using Safe Boot currently. On boot, immediate flickering occured and everything feels really slow (relatively simple animations take about 5 seconds to complete). Firefox crashed several times. No persistent graphical issues detected so far. I used the EtreCheck application and edited the post with the results. – Pepijn van Leeuwen May 12 '15 at 20:18
  • @Buscar웃 I will run the hardware test now. – Pepijn van Leeuwen May 12 '15 at 20:28
2

Let me guess: the issue appeared with the 10.10.3 update? Well, then I am 98% certain it is a bug in OS X Yosemite. Your issue is related with this one.

Users report erratic kernel panics and some users have graphics glitches like you. The only common feature is having a Intel HD 4000 GPU.

On MacBook Pros with dual GPU you can avoid the problem by disabling Automatic Graphics Switching (System Preferences > Energy Saver).

Please contribute to the thread in the apple discussion forum and file a bug report (with link to the thread).

1

What you describe in the post and the comments is definitely a dying GPU.

I am deeply sorry for your loss.

#AlsoLostAGPUOnMyMac

  • Thanks for your response. That's really unfortunate. Luckily I have a insurance that might cover the repair costs. I will make an appointment with the Genius Bar this week and discuss it with them. – Pepijn van Leeuwen May 13 '15 at 9:14
1

Hi I believe it's not a dying GPU because we have same issue in all our MAC's.

It started after Yosemite upgrade.

https://www.dropbox.com/s/n04b4tmbbggkftd/wierdvideoproblem.mp4?dl=0

It may be Little Snitch. I disabled network traffic activity monitor, because glitch update pattern is like a data transfer pattern.

I'll post updates.

  • We also have lots of kernel panics (twice a day), but with always different back. We have Samsung EVO 850 in common. This might be the cause? – Zamazing May 20 '15 at 16:58
  • I am not sure the Samsung EVO 850 is the cause of the issue, but I will try my old HDD this weekend. I feel like Little Snitch might be the cause, because I remember that these graphical rendering issues started after a Little Snitch update (most recent version). Also, when I am using Bootcamp, I don't seem to have any issues. Thanks for your response! – Pepijn van Leeuwen May 21 '15 at 7:05
  • After disabling the Network Monitor I have had no crashes or odd graphical rendering issues. So far, so good. I will get in touch with Objective Development to report this, as it seems like a rather major bug. – Pepijn van Leeuwen May 21 '15 at 21:10
  • Also, these users (on the Objective Development forum) report the same issues as well: forums.obdev.at/viewtopic.php?f=1&t=9758 – Pepijn van Leeuwen May 22 '15 at 17:29
-1

Turning off Little Snitch network monitor and automatic graphic switching seems to have worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .