12

What is this "1" alerting me to? There does not appear to be anything in any of my Calendars that is requiring my attention. How can I get rid of this?

enter image description here

I'm using a clean installation of Yosemite.

7

To fix the problem, open Terminal and run (case sensitive):

killall Dock

This will shut down the Dock, and macOS will reopen the Dock immediately. When the Dock fetches the current state of notifications from Calendar, it will see zero pending notifications, and the badge will not show up.

I've had this issue a few times. MacOS has some sort of bug that causes a badge to show a number of active Calendar notifications, even though there are none in Calendar itself. I've most often seen this issue when someone is sending out multiple calendar invites and updates in a short period (e.g. someone creates a meeting, then sends several updates to change the time, location, notes, etc.). I'll respond to each update one by one, and afterwards the badge will still show a "1", even though the notifications list in Calendar is empty.

This is actually a problem with the Dock. In macOS, the Dock is responsible for showing and updating application icons, including badges, check marks, progress bars and other state information that applications want to display. Occasionally, it seems, the state of the Calendar Dock icons gets corrupted or out of sync with the state of the Calendar itself. (This happens with other applications, too, e.g. Messages.)

  • Dock always runs under your user, so you'll never need to sudo killall? – grg Feb 18 '17 at 18:52
  • @grgarside: Good point. Editing to reflect that. – Andrew Feb 19 '17 at 2:24
  • This did not work for me. @ph4n70m's suggestion below, however, did work. Bad UI there, Apple. – Torenware Networks May 20 at 0:04
18

The badge is notifying you of a Calendar notification. There are two cases which causes a badge:

  • You've been invited to an event.
  • An event on one of your shared calendars has been modified.

To clear the badge, open Calendar and click Notifications on the toolbar, then take action on the notification by selecting Accept/Decline/Maybe on an invitation or OK for a change notification.

Also see What's this button on Calendar.app? regarding the Notifications button on the toolbar.

  • 1
    Strange. There's no such button in Calendar for me :-/ – Django Reinhardt May 12 '15 at 15:55
  • @Django What about View → Show Notifications? – grg May 12 '15 at 15:57
  • 1
    I don't see any such option? i.stack.imgur.com/wMCHF.png – Django Reinhardt May 12 '15 at 16:44
  • @Django It's greyed out, so you apparently don't have any notifications. This seems like a bug. Try resetting notification settings in System Preferences. – grg May 12 '15 at 17:03
  • 1
    Wow. This is disappointing. This is a totally clean installation of Yosemite (from a USB installation -- completely wiped the HD). I'll give your suggestion a try. – Django Reinhardt May 12 '15 at 17:13
4

Use this button in the calendar app:

enter image description here

2

I have the same problem in El Capitan 10.11.5 with Calendar 8.0.

Fixed it with a solution based on Django's tip in a previous comment:

  1. Quit Calendar
  2. Switch off all notifications for Calendar in System Preferences
  3. Launch Calendar
  4. Switch the notifications back on
2

What worked for me:

  1. Open Terminal
  2. Type the following command, CASE SENSITIVE!

killall Dock

The problem seems to be with the Dock, not the notifications function

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .