I've got my Macbook Pro (early 2015) set up with Boot Camp. Normally, when I switch it on, OS X starts. But I can press Alt/Option to get the boot menu, and select Boot Camp Windows from there.

Once I've booted into Windows, though, Windows becomes the default OS! So, after booting Windows, then shutting down, when I next switch it on, Windows starts. If I want OS X back, I have to select OS X from the boot menu, or use the Boot Camp section of the Control Panel to change the boot option.

Is there anything I can do about this? I want my computer to always boot into Mac OS X, even if I last opted to boot Windows, unless I go via the boot menu. My old Macbook Pro (mid 2009) worked that way, and I've come to prefer it.

  • This appears to be the new default, as it works this way for me as well. I'm guessing rebooting into Mac by default was causing problems when Windows rebooted to apply updates.
    – tubedogg
    Commented May 12, 2015 at 16:31
  • You can add the script menu to the OS X menu bar which will allow you to boot to Windows from OS X without making Windows the default. Also you can install a free copy of the rEFInd boot manager which will force the computer to always boot to OS X. I would test rEFInd using a flash drive first, before installing on your internal disk. If you choose to install rEFInd on the internal disk, I would install to its own partition. Commented May 13, 2015 at 7:26
  • It's actually even worse than I thought - once Windows has been magically made the default (simply because you booted into it once), Mac OS has to be made the default again explicitly!
    – Tom Seddon
    Commented May 18, 2015 at 21:24

2 Answers 2


Download BootChamp. You get a shortcut that reboots into Windows, but it doesn't change the default OS. Seems to work really well.


I have a 13" MacBook Pro (late 2011) running OSX 10.9.5. To resolve this issue go to system preferences > Start Up Disk > select Macintosh HD

  • This is the setting that is overridden next time you boot Windows.
    – Tom Seddon
    Commented Jul 9, 2015 at 18:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .