2

I'm using a MacBook Air 13" mid 2012 with Yosemite 10.10.3, it rebooted itself this morning without a reason and since then the screen saver is no longer asking for a password on unlock.

This is a great security flaw but I can't find a solution, I've tried modifying the security option by unchecking and checking everything again but it just does not work.

Anyone had this issue and know how to fix it? I use the device for work so it must always ask for a password before unlocking.

  • How did you tell to to ask for a password on unlock? – Mark May 11 '15 at 16:20
  • From security & privacy > General > Require Password "immediately" after sleep or screen saver begins – Matteo May 11 '15 at 17:07
  • And is that still checked? – Mark May 11 '15 at 17:11
  • I've already described the situation Mark, yes it is checked – Matteo May 11 '15 at 17:15
  • Do you have multiple monitors setup? If yes, unplug them all, restart and try again. Also check if you chose require password "immediately" If the problem persists, try also unplugging bluetooth devices. And if that does not work: Try navigating to ~/Library/Preferences and dragging com.apple.systempreferences.plist to desktop. If it does not work, put it back. – TheBro21 May 11 '15 at 20:47
1

I've tried using backups and it did not solve the issues, after 3 reboots the problem disappeared without changing anything at all.

I don't know the reason or why it fixed itself with just several reboots, but seems a good solution.

I hope someone will discover the cause and a proper solution.

  • I am also seeing this on Yosemite with Macbook Air. Things were working as expected until one day it just stopped prompting. I am loathe to reboot 3 times but I will try. – spartygw Jul 31 '15 at 19:56
  • 1
    Rebooting fixed it. Odd. – spartygw Jul 31 '15 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .