I just recently bought an iPhone 4.

It came with 4.2.1 firmware, and since 4.3.4 is released now it is not as simple as to just update the firmware with itunes. I have tried some good thing which tells you to use TinyUmbrella, but I didn't got it to work as I got error message 1604 when trying to restore. Anyone know how to upgrade to 4.3.3 firmware?

  • 1
    When you connect to iTunes, and ask iTunes to get the latest firmware for this device, what happens? I'm assuming a non-jailbroken iPhone, of course. – GEdgar Jul 25 '11 at 18:22
  • it will ask if I want to update to the latest version of firmware. But I want to update to 4.3.3, thus I need to use tinyumbrella for it. – starcorn Jul 27 '11 at 14:42

TinyUmbrella is probably stopping you from updating your iPhone, because that creates a service that redirects port requests to itself rather than the Apple servers. I do not recommend using TinyUmbrella for anything unless you know exactly what it does and how to use it.

The reason you are having troubles is because you are probably trying to install the wrong IPSW file onto the iPhone.

Download the latest iTunes and install it (this will automatically update it) and then connect your iPhone, and in iTunes, request it to check for any iOS updates.

iTunes will download the required IPSW, get a certificate request from Apple servers and then install it. Problem solved.

| improve this answer | |
  • -1 You need SHSH blobs to upgrade to a firmware that isn't currently being signed. TinyUmbrella would work if he had blobs (since we're talking about iOS 4 here). The answer to his question lies with the fact that he does not have blobs for iOS 4.3.3. This is a pretty hardcore necropost, too. The answer is irrelevant now. – Andrew Larsson Oct 7 '13 at 21:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .