0

I'm at my wits end here with a new Mac Mini. I bought a brand new mac mini, took it home, and did nothing but create a user account. When I try to connect to my network (Comcast Xfinity), I continuously get a "connection timeout" error before it even authenticates my password. The same thing always pops up when I try to connect to ANY network around me, even using my phone as a wireless hotspot. However, another MacBook Pro, iPhone 6, Lumia 920 (Windows Phone), and Surface Pro 3 in this apartment are able to connect without ANY issues whatsoever, so it is definitely isolated to my mac mini.

I took it into the apple store today, and they decided that it would be easiest to just give me a new mac mini. I tested it out at the store, and it was able to connect to both an open and a WPA2 encrypted network. Brought it home, and NOTHING. Connection timeout!

Here are some things I have tried:

  1. Creating a new location inside network preferences with other options removed.
  2. Removing password on network and making it open.
  3. Restarting Mac Mini and router.
  4. Changing channels on my router with random ones from 1 to 11.
  5. Changing ipV6 to Link-only (someone recommended this).

I cannot find any more suggestions on google, and apple's phone support is fairly unreliable. I am so frustrated with this...I am normally a windows person, and was really expecting a magical out of the box experience, not this. ANY help would be greatly appreciated. I will post whatever logs I can to help out!

Here are my machine specs:

OS: OS X Yosemite Version 10.0.1

Hardware: Mac mini (Late 2014) -2.6GHz Intel Core i5 -8 GB 1600 MHz DDR3 RAM -Intel Iris 1536 MB graphics

Thank you so much guys!

  • I have a brand new mac mini and can't connect to my wifi network unless I unplug the power cord for at least one minute before booting it. – user159330 Nov 28 '15 at 16:31
1

It's a combination of the Mac mini and the xfinity router. I've had this problem with multiple Apple devices over the years, but only when using the xfinity router. Do yourself a favor, buy a really good router and just use a cable modem. I guarantee this will fix the problem.

  • Oh gosh, that's irritating. I am tied up at a internship and unfortunately am not allowed to change the internet at the housing provided for me. Is there anything else I can try to do? – Flying Lawnmowers May 12 '15 at 3:47
  • Well... change the router without authorisation when nobody else is using it? And set the new one up with the same wifi name and password as the old one, so other users wouldn't figure it out, since their device would connect automatically to the new router? – ssssaaaa Feb 19 '18 at 20:21
0

Not sure if you tried, but move it to different location, to see if it is a signal strength.

Or turn all other devices off from wifi to see if you have channel crowding.

Open the Router set up page and look if MacMini is showing in it.

Lets try to connect using Terminal, please follow the steps.

Manually connect to WiFi

Turn On

networksetup -setairportpower en0 on

Find

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

Connect

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD
  • And as it connects at an Apple store and not elsewhere you might want to call Xfinity support and see what they say. There might be a known issue that they (hopefully) have a fix for... – Steve Chambers May 10 '15 at 16:04
  • Ok I'm getting a very strange error Buscar웃 I can find my network with "airport scan" command, but then when I try to connect to it, I get the following: 'Error: -3905 The operation couldn’t be completed. (com.apple.wifi.apple80211API.error error -3905.)Harshas-Mac-mini:Resources I cannot figure it out. Searching on google for the error turns up Apple TV error codes. Also, I have tried moving the computer pretty much everywhere :\. – Flying Lawnmowers May 10 '15 at 20:42
  • this article might help nakedsecurity.sophos.com/2014/10/22/… – Ruskes May 10 '15 at 21:04
0

Is there an "Automatic" location? I can remember when I first got my Mac Mini I was having trouble with the networking. I set it to "Automatic" and it worked fine.

0

I found on another site and thought I would share because this was a pain in the &%&$#. I tried all the suggestions and then I found one answer that worked IMMEDIATELY and it's so simple. I have 2 external hard rives connected to my mac mini and it seems they were somehow interfering with the wifi and bluetooth signals. All I had to do was move them about 6 inches away from the mac mini. DONE! At first I just removed them to test but then was able to just make sure they were not right next to the Mac Mini.

You must log in to answer this question.

protected by Community Nov 24 '17 at 19:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .