0

My available disk space seems to «vanish» magically.

OmniDiskSweeper tells me that 69.5 GB data is on my hard drive, but how come Finder and Terminal (and OmniDiskSweeper's drive list itself) tell me that 110.7 GB is being used? OmniDiskSweeper

I can't find the remaining 41 GB of space on my own, I don't have any backups on my startup disk, I tried a lot of things: Rebooting, installing updates, looking through my Application Support folder, Clearing caches, First Aid in Disk Utility app, CleanMyMac, ...

I only have one partition and according to OS X's Disk Utility there's no disk space not assigned to a partition. I don't use File Vault at the moment and I never used it before; same thing with Time Machine. OS X's menu option «About My Mac» first told me Apps would use about 70 GB, which was clearly wrong, so I rebuilt Spotlight Index using Terminal. Now it shows 15.08 GB as «Apps» (which is correct) and 87.52 GB as «Other».

Where are the 41 GB that never show up anywhere?

  • When running check volume on the partition does disk utility not give any errors? – Kevin Grabher May 9 '15 at 19:18
  • @KevinGrabher No errors at all. – Stefan Wittwer May 9 '15 at 19:25
  • 1
    Is OmniDiskSweeper running with administrator privileges? Maybe the app cannot access all folders so it is not counting everything. What is the command du -x -sk /* say when you run it from Terminal? – Vic May 9 '15 at 19:32
  • @Vic Thanks for the tip! Found that com.apple.coresymbolicationd and .DocumentRevisions-V100 make up the remaining 41 GB. Problem solved, thank you – Stefan Wittwer May 9 '15 at 19:36
  • @StefanWittwer I've posted it as an answer. Please accept it so everyone knows it has been answered. Cheers. – Vic May 9 '15 at 19:42
2

OmniDiskSweeper may not be running with administrator privileges and it cannot access all folders, therefore it is not counting everything.

The command du -x -sk /* in Terminal may give you a better/correct result.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .