2

I recently got an iPhone 6 (iOS 8.3, Verizon), and I've been having recurring issues with Google's apps not being able to access the network when on LTE or 3G (Gmail, Google, Inbox, Play Music, etc). The problem does not occur over Wifi, but my LTE/3G connection is perfectly reliable for non-Google apps (streaming video with Netflix works great).

I tried the following to troubleshoot this issue:

  • Uninstalled every Google app from my phone
  • Cleared the iCloud backups for all of them
  • Installed Gmail app. It prompted me to sign into my account (not sure how it prepopulated my account after being uninstalled), but could not connect to the network. I removed the account from the Gmail app, uninstalled, reinstalled, and still no network.
  • Turned on wifi to verify that the app was able to connect. It was, instantly. Turned off wifi and reloaded the app - no connection. Verified good LTE connection in other apps.

Restarting the phone fixes the issue and the Google apps work over LTE/3G again, but the problem recurs every couple days, and the only solution is to turn the phone off and on.

Any ideas? The fact that the problem persists across uninstallations and is only solved by a reboot of the phone seems to indicate a problem with the iPhone rather than Google apps, but the fact that the problem is isolated to Google apps would indicate otherwise. I'd take it to the Apple store, but I have a feeling they'd just tell me to contact Google.

Update

When the issue is occurring, I can access google.com via Safari and via Ping Analyzer.

  • 1
    You speak of LTE — do the problems persist with 3G connections as well? (Do you know how to switch from LTE to 3G? I have a non-english iOS here so my instructions for LTE/3G switching are not useful for you, probably) – myhd May 15 '15 at 15:41
  • 1
    Do you have any problem accessing Google apps through Safari, directly? Maybe your Internet provider (Verizon) is giving you a bad connection to Google services (e.g. through their DNS servers). If you have the same problem with Safari, then that's the case. Otherwise, there are hundreds of options available yet... – lnjuanj May 16 '15 at 16:13
  • 1
    Does the iPhone use the same broke discoveryd as the mbp on yosemite now ? if so, that can / will snag out dns requests to *.google.com – linuxdev2013 May 17 '15 at 12:52
  • 1
    It might be worth resetting the network connections on your phone. Go to Settings -> General -> Reset -> Reset Network Settings to force it to revert all cellular settings back to default. – smoooosher May 19 '15 at 18:37
  • 1
    I took my phone to the Apple store, and they replaced it. Not sure what the issue was, but the new phone doesn't seem to suffer from it – Eric May 26 '15 at 15:28
1

Tetsujin's answer helped me, although my problem wasn't exactly the same as his. Google and Google maps weren't yielding results, and I blamed my service provider for crappy coverage, although other apps were working. I went into Settings -> Cellular as per Tetsujin's instructions, and found that Google and Google maps were turned off under "Use cellular data for"... Turned them back on, and they now work. When setting up my phone, I had set up Google apps conservatively to keep the MoFos from snooping on me. Turns out that totally invalidates them when not on wifi....

0

Check if you have disabled the Mail under Settings --> "Cellular"

0

Old post but worth posting the solution which I found as I had this problem for 4 years and got it resolved today.

Every other forum gives the same set of instruction, but you can try this. May be your problem might be similar to mine, as I had disabled cellular connection for the Setting apps when iOS gave the option to turn on /off cellular data for individual apps in some iOS update, which I don't remember

Go to Settings>Cellular
Scroll down to Use Cellular Data For
Make sure you enable LTE connections for the below apps

  1. Settings---- This is the culprit. Mail configuration is done in Settings apps in iOS. So enable Cellular for this apps. Because your cursor control comes back to the settings application after entering password in the inbuild Safari browser used by gmail.
  2. Calendar- optionally you can enable LTE , because google come with sync option for calendar during initial configuration. You can disable it later if you don't manage your Calender with your gmail account.
  3. Contacts - this is similar to calendar apps. if you don't manage your notes with gmail, You can disable it after configuration
  4. Notes - this is similar to calendar apps. if you don't manage your notes with gmail, You can disable it after configuration.

Enjoy

0

goto google browser setting, click bandwidth and pre-load web page - select "always" (do not select only on wi-fi). mine had similar problem when i'm on 4g network and taking too long or unable to repsond to the webpage. no issue when i'm using wifi connection. hope that helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .