4

When I share photos from Instagram to Facebook (using the Instagram app on iOS), by default they get "Only Me" sharing visibility:

enter image description here

That doesn't seem very useful to me - I'd rather my friends saw them. In fact, Instagram's help page says that is what is supposed to happen.

How can I fix this? How can I make these photos visible to my friends by default?

  • As this is a question about an iOS app rather than a web app, this question would be better off at Ask Different. – Al E. May 8 '15 at 0:59
  • I don't really agree; although the source of the share is from an iOS app, I suspect the answer lies in Facebook.com privacy settings. But it's obviously hard to tell without an answer... – Andrew Ferrier May 8 '15 at 2:09
7

As Andrew Ferrier stated in the comments to the question, this is indeed a part of Facebook's privacy settings. Here is how you set it to share to "Friends" by default:

  1. Go to your Facebook.com.
  2. Find the page to edit your Instagram settings.
  3. Change your App visibility and post audience setting to Friends

    This setting controls who on Facebook can see that you use this app. It also allows you to choose the audience for posts the app makes on your behalf.

Hope this helps you.

  • 1
    Perfect! Exactly what I needed. – Andrew Ferrier May 8 '15 at 3:36
  • I could kiss you! Why on Earth it's that difficult, I can only guess – Dov Dec 5 '18 at 3:57
  • Personally, I couldn't find Instagram in Settings > Apps, but I did find it in the "More" drop-down menu. – mblakesley Nov 18 '19 at 23:24
  • 3rd bullet point worked perfectly. – Carlos Nov 29 '19 at 3:15
  • 3rd bullet point for me as well. More->Instagram(dropdown item)->Manage(pencil icon on the right in the instagram section) – sr9yar Jan 11 at 9:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .