I am on OSX Yosemite 10.10.3 on MacBook Pro (Early 2011) and I am not able to connect to internet from any browser except chrome. I am not even able to ping from terminal as well. Please help.

When I try to use diagnostics Internet and Server shows Red, rest all are Green.

  • You mean a simple "ping google.com" does not work ? what does it say ? – Buscar웃 May 7 '15 at 18:10
  • Nope. Simple "ping google.com" does not work either. Pravins-MacBook-Pro:~ pravinhmhatre$ ping google.com ping: cannot resolve google.com: Unknown host – Pravin May 8 '15 at 16:41
  • I had to reinstall Yosemite. Able to connect properly now. – Pravin May 12 '15 at 9:51
  • Same exact problem happened after I installed El Capitan. I noticed that my root certificate is untrusted, but I'm not sure if that's at all relevant to the problem. Network preferences does not appear to have a "verify IP" option. I'll try harder. – user158090 Nov 18 '15 at 22:18

Open Network Preferences, and:

  • verify IP

  • verify gateway

  • verify DNS

Your IP address is either static or dynamic. Static: you put in your IP info. Dynamic: your gateway provides the correct IP info.

Open Terminal.app, and type:

 ifconfig -a 

That will show you what network interfaces you have. One of these is your primary route and your default gateway. You can only have one default gateway. Even though you may have many interfaces (ethernet, wireless and firewire, etc), there's only one default way to go if the request is not local.

So check for default route by typing in Terminal.app:

netstat -nr | more

The top two resulting lines will tell you who's the boss.

Then ping the gateway.

ping <IP address>

If it doesn't work, reboot and try again. You should at a minimum ping your gateway and ping your DNS before it's worth it to troubleshoot individual applications.

  • 1
    all is fine, but does not explain why Chrome is working and the others not! – Buscar웃 May 8 '15 at 17:09
  • I am able to ping gateway which is 192.168.0.1 and DNS which is 103.17.159.50 – Pravin May 8 '15 at 17:11
  • @Pravin that would be your Router. Did you check the settings of your router so it is not blocking stuff. – Buscar웃 May 8 '15 at 17:22
  • I tried connecting from different network and even from mobile hotspot. Still same issue.. :( – Pravin May 9 '15 at 6:35
  • @Pravin well it looks like some think this is the correct answer! does it work for you? – Buscar웃 May 9 '15 at 7:02
up vote 1 down vote accepted

I had to reinstall Yosemite. Able to connect properly now.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.