5

I have 3 macs that all produce this error repeatedly in the console, and I cant figure out the root cause of it. It leads to various system stalls and memory issues.

(Currently troubleshooting on Yosemite 10.10.3 on a 2011 imac, 8 mb of RAM.)

5/6/15 11:21:31.433 AM com.apple.xpc.launchd[1]: (com.apple.xpc.launchd.domain.user.502) Service "com.apple.xpc.launchd.oneshot.0x10000038.AppleSpell" tried to hijack endpoint "it (Apple)_OpenStep" from owner: com.apple.xpc.launchd.oneshot.0x10000004.AppleSpell

Ive read through various forums, some suggest its a hard drive failure, but all tests have shown my drive is totally fine, and because its a problem occuring across 3 different machines, I doubt its a HD issue.

From what I understand, this is created by the systems system wide-spell check system. This error hits the hardest when I have any mail applications open (mail, outlook, airmail, etc).

Has anyone discovered a fix to nip this issue in the bud? Id like to avoid disabling it completely - but if it comes to that, is there a way to do so? Ive already disabled the option within Yosmites PrefPane.

Any help would be vastly appreciated. I miss having my sanity.

1

Let’s dig into the stalls and memory errors directly as this message cleared up for me on updating the OS. Any chance you would like to make a follow up question, just link in the comments below and I’ll gladly have a look.

There are more than one libraries, and you’re calling the older one and not the newer one, so this is just a versioning issue that happens from time to time AFAIK.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .