4

I have 30,000+ photos synced to iCloud and am trying to get their thumbnails to show on the Photos app on iOS 8.3. On the (first) Photos tab, viewing at Years or Collections levels shows lots of grey placeholders instead of photos. Only when I click into Moments do the thumbnails actually load.

However, trying to scroll through all my photos at the Moments level, to trigger downloading of the thumbnail, would take hours. (It's a little faster under Albums > All Photos, but not much.)

Is there a way to force all the thumbnails to download? I tried disabling iCloud Photo Library and re-enabling it, but it did not force a sync. Note that I have Optimize iPhone Storage set, but I thought this should still download thumbnails.

4

I am having a similar problem. All of my iOS photos have synced up to Photos on the Mac, but photos that I've added on the Mac show up blank in iOS. When I click on a photo, a blank comes up, with a progress clock in the lower right corner. However, that seems to stall at 25%. Even when I go into Edit mode, it appears to start downloading and appears to give up after 25%.

I may try to turn off iCloud Photos and try again, but I have nearly 70k photos and videos.

  • Did you find a solution? Same happens in 8.4.x – mplungjan Sep 6 '15 at 19:15
  • still happens for me, IOS 9 – Bahadır Yağan Nov 18 '15 at 7:02
0

The thumbnails should all be (eventually) downloaded, but with that many photos, it may take some time. Panning over them simply tells the system to hurry up and retrieve the ones you're trying to look at.

On the Photos (left) tab, zoom all the way in and scroll all the way to the bottom, and it should give you the current sync status. "XX,XXX Photos, 15 items to upload" or similar. It may also say "preparing items", which also takes some time as it sorts through what's on your phone. Either way, unless it says "Updated [just now | some date]", it is still working on it.

  • I originally thought that was how it works, but I don't believe this is correct. It has completed preparing the photos. In the Moments view, I see a working icon next to Wi-Fi in the menubar when I view grey placeholders while thumbnails are downloaded. Once they are downloaded, and in all other views, I don't see that icon and new thumbnails do not download. – Dan Kohn May 6 '15 at 18:59
  • How long has it been since you turned iCloud Photo Library back on? For me, with ~10k photos, it took almost a day for all of the thumbnails to be downloaded. – tubedogg May 6 '15 at 19:01
  • A couple days ago. I keep thinking there's some view I could go to that would force the download to start, but I haven't figured it out. – Dan Kohn May 6 '15 at 20:25
0

I've had almost all of the same probelms. I ended up calling Apple and they had to do a hard reset on my iCloud from their end. Bad thing is, you have to re-download all of the photos again (not fun when you have 16,000+ photos on 4 devices).

0

Zoom out until you're in "years" view and disable "Summarize Photos" under Preferences > Photos & Camera.

That will help, now you just have to scroll through your photos once and they will be downloaded.

0

Under Preferences, choose automatically lock screen option to "Never". Then, open Photos, go under the thumbnails view and let run.

-1

I found none of the above to work. The best solution I found was to hold your finger down in the year view to scrub through the pictures. Where you scrub it triggers the thumbnails to download. Not great, but it works.

-1

Here's what worked for me: Quit Photos; run Activity Monitor and search for iCloud Photos process and terminate it; re-open Photos and within a min the photos start to reload.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .