0

I need to wipe my Mac Mini and reinstall OS X. Booting into recovery mode (holding command+option+R), I try to erase the disk in Disk Utility but it says it cannot unmount the disk or gets stuck on "Unmounting disk" with an infinite loading progress bar.

I have also tried booting into the recovery partition by holding down option at launch, but the same applies.

  • There must be something active on it that does not let it unmount. Did you try using Terminal ? – Ruskes May 5 '15 at 18:06
  • I tried unmounting via terminal but the only thing that shows up under /Volumes/ is the base partition :( – Chris May 5 '15 at 19:28
  • Try resetting you PRAM/NVRAM. See Cannot Unmount Mac OS X Base System Disk. – David Anderson May 6 '15 at 11:03
1

Way by Terminal..

Use diskutil list in a Terminal instance to list all volumes and find yours.

Then do hdiutil eject disk?

Replace the ? with your disk number, making sure you are not trying to eject the main hard drive :) It is probably called "Disk1"

Here is a Sample when I insert a USB stick and run diskutil list

diskutil

disk0 is my hard drive and I can NOT eject that one

disk1 is the USB and I cam eject it.

  • hdiutil: couldn't unmount "disk0" - Resource busy – Chris May 5 '15 at 19:31
  • There you go, now we know it is busy with something :) Warning, make sure you are unmounting the right disk, as shown in the diskutil list. – Ruskes May 5 '15 at 19:34
  • How do I unbusy it? I just want a fresh install, no need to have any data recovered – Chris May 5 '15 at 19:34
  • Warning...it is not the disk0, check again, it is probably called Disk1 – Ruskes May 5 '15 at 19:37
0

You can't unmount the entire disk from the Recovery Partition as it is part of that disk (disk0), and therefore in use.

You need to make sure you are trying to erase the partition (probably called "Macintosh HD"), and not the entire disk.

If you want to wipe the entire hard drive, you will need to use an external, bootable volume to boot from.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .