0

The sound output is not stuck in digital mode, actually the output is stuck in "headphones mode". It works when the headphones are plugged in.

Plugging in or replugging the headphones does not change mode from headphones to digital, it stays on headphones. It does not solve the problem either. There is no red light. Instead there is a white light. Blowing at it failed to work.

3
  • What does the console say when you plug in and out your headphones? Could you paste? Or if too long, use pastebin and incl. a link? And have you checked your audio settings
    – John K
    May 5 '15 at 9:39
  • What does it say when you Alt + Click the sound menu item? Are the sources set correctly with and without headphones? cloudup.com/c6LOmsM9T6L
    – Tum
    May 5 '15 at 11:05
  • stuck in headphone mode in the settings on "output" , console doesn't say anything
    – Jake
    May 5 '15 at 13:04
1

I had a similar problem when I used an older version of AirParrot, it would not switch the Audio back to Built-In. Had to manually go into preferences.

If you checked the System Preferences -> Sound -> Output and System Preferences -> Sound -> Sound Effects and it does not show Built-In option when headphones are out:

  1. Make sure there's nothing stuck in the AUX port, no dust pieces or anything. Or is it USB headphones?
  2. Then I would reset PRAM and NVRAM to clear your computer's inner caches. If it resets it and makes it right until the next time you plug teh headphones in and it happens again, try different headphones, does it do the same?
  3. Try to get your hands on another bootable copy of Mac OS, could be you may need to reinstall the System folder, which should not affect any of your data. Just select this option when you do a Restore (but backup your system anyway).

If still the same, I would bring it in to Apple store since they will diagnose it for free.

1

My MB Pro spec: MacOS BigSur

I had the same exact issue (occurring randomly)

How I fix it:

  • Remove the headphone jack.
  • Put the Mac to "Sleep".
  • Wake it up again.
  • Now I see that audio has switched to "Internal Speakers" again.
0

Try booting into Safe Mode, by holding down the Shift key when restarting your Mac. If the problem persists even while in Safe Mode, then it is a hardware issue. There is a small little micro-switch inside that can fail or get jammed with dirt. If you can't get it to work by using a can of computer cleaner compressed "air" (it's actually butane, IIRC) then you probably need to get a new headphone jack (and the board that it is attached to).

Depending on your model, you can probably just replace the I/O board, following some instructions like the following from iFixit: https://www.ifixit.com/Guide/MacBook+Air+13-Inch+Mid+2011+I-O+Board+Replacement/6364

If you're not the DIY type, then I would look up an authorized repair place from Apple's lookup tool: https://locate.apple.com/

Good Luck, and I hope it is a simple fix!!

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .