7

How do I disable WebEx Assistant on startup for Mac? I dont want to remove the application completely, but I dont want it to launch automatically at startup.

3
  • is it in your settings to start up at boot? – Ruskes May 5 '15 at 0:17
  • I didnt know where to look... @Tetsujin pointed me to the right area. – user3621202 May 6 '15 at 20:54
  • happy ending :) – Ruskes May 6 '15 at 22:14
7

Try System Prefs > User & Groups > Your name > Login Items.

Select it in the list & click the - button underneath

If it's not listed there, then check either /Library/LaunchDaemons/ or /Library/StartupItems/ to see whether it has an entry in there.
It's safe to remove items from there - though they will continue running until the next reboot.

If you want to be able to restore functionality in future, zip the file in situ then trash the original.

1
  • Thx you so much. This was exactly what i needed to know. It worked great. – user3621202 May 6 '15 at 20:54
2

I tried removing this from the user's Login Items, but it re-appeared each time I started the app. I could not find it in any of system or user launch or startup .plist files.

Then I noticed that the "Preferences" menu, where this sort of thing would normally be configured was grayed out. So I went looking for Webex plist file itself.

Turns out if you look at ~/Library/Preferences/com.cisco.webexmeetingsapp.plist you'll find a key called PTLaunchAtLogin.

I used a text editor and changed it to "false". If the file is not readily editable directly and Xcode it's installed on your Mac, simply double click the .plist file and toggle the key to "false".

Problem solved.

<key>PTLaunchAtLogin</key>
<false/>
1
  • So I removed it in System Preferences and it loaded at start anyway, then I opened the .plist as described in this answer and <false/> was already there...and it continues to load at startup. – Scooter Dec 8 '20 at 2:56
0

There are multiple locations where an application can place configuration to achieve autostart or "automatically restart" if stopped. Some don't autostart but setup a scheduled daily start.

I'm using a (commercial) tool to detect those and disable such behaviour: Lingon X. It's basically a GUI for launchd. I especially like the feature that it alerts me if something is added or modified.

0

DaveANP has this pegged. I had already tried the accepted answer of removing from login items, but it kept reappearing there. Yet another reason to use another platform for meetings.

~/Library/Preferences/com.cisco.webexmeetingsapp.plist was not readily editable directly, but opening in Xcode made it trivial to set this boolean to FALSE.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .