1

I have 3 iPhoto Libraries. Have already converted 2 of them. Went back to open the first converted and it would not open. Nothing.

I can select the other two, but when I try and select the 3rd, nothing happens. I click, the button registers the click, but nothing happens.

Here is a screenshot - I click Choose Library and nothing happens.

click choose library nothing happens

I can select the other libraries, no problem.

1

That Library is showing as a .migratedlibrary file, which means it's already been 'translated' to Photos format & can no longer be opened in Photos.

The contents must be in one of your other libraries in the list, or if on a remote disk, you may have to open it fro the `Other Library…' button.
By default, the new Photos Library will be in the same location as the old iPhoto Library it was imported from.

From How Photos for Mac handles iPhoto imports

So, when Photos migrates an iPhoto library, it changes the file extension on the iPhoto library package to .migratedphotolibrary and makes a hard link to all iPhoto media assets in its own library package, using the same directory structure as iPhoto.

0

For some reason, renaming the iPhoto Library and then relaunching Photos worked. It loaded just fine.

0

I found that trying to open the .photolibrary bundle manually in Finder worked just fine when only the .migratedphotolibrary bundle showed up in the choose library pane.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .