2

I'm experiencing what I'm pretty certain is new behavior since switching from iPhoto to Photos. When I tell iTunes to sync my photos from the last month, I get photos going back to 2006.

My iTunes sync settings look like this:

Here's what I did:

  1. unchecked "Sync Photos" and did a sync to clear everything out
  2. clicked "Selected Albums" and unchecked every album
  3. checked "Automatically include photos from" and selected "Last month"
  4. did another sync

And that's when I got photos from 2006 when I was expecting only the last month's photos. I have a hunch that this is because the iPhoto --> Photos migration set the modified dates to that day...but don't quote me on that, because the photo files themselves retained their original dates.

This is what the dates look like on the photo folders:

Is there any way to get the actual photos from the last month?

Software/hardware: iTunes 12.1.2.27 on Yosemite 10.10.3 (14D131), and iOS 8.3 (12F70) on an iPhone 5s.

  • The key word here is "Include" it means to what ever you selected to include (add on) the last month as well. – Ruskes May 4 '15 at 0:08
  • The modified dates have no bearing on what is synced, only the original dates of the photos as set in their metadata (and shown by the year folder structure you have seen). You verified after "unsyncing" that everything was actually removed from the phone? – tubedogg May 4 '15 at 3:18
  • Also did you look through the last month in Photos and confirm that it doesn't include photos in error, that you are saying are from 2006? – tubedogg May 4 '15 at 3:19
0

You should check the iPhoto/Photos app and see if any of your 2006 photos are in the Last Month tab or the April 2015 tabs. If they are then the problem is with the photos' dates, not iTunes or your iDevice.

0

I've confirmed that all the dates for all the photos are correct. I'm really not sure why iTunes is syncing more than what is checked, but here's my workaround:

  1. Create a Smart Album in Photos with the parameters Date is in the last 30 days. This should correctly bundle together the photos by date.
  2. In iTunes (you may have to quit/reopen for the album to show up), tell it to use Selected albums, uncheck Automatically include..., and check only the new Last 30 days album.
  3. Sync!

Now you should get only the last 30 days of photos.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .