2

I use a Tascam US-122mkII audio interface to record music with. I recently upgraded my Macbook to OS X 10.9.5 and tried to update the drivers for my Tascam but they don't seem to be installing correctly. The control panel for the interface displays a blank after the 'Driver Version' label. Consequently, I'm not currently able to use the device.

I have tried uninstalling and reinstalling the driver several times but it makes no difference. I have also tested this on another computer running Mavericks and it seems to work fine, so I don't think it's a conflict with the operating system. Somebody suggested that perhaps there is a conflict with traces of the previous driver still on the system. Is there anyone who can tell me how to check this or offer any other suggestions? Tascam were unable to help.

Yours hopefully,

M

2
  • Did you actually get the latest drivers, specifically for Mavericks & Yosemite? tascam.com/product/us-122mkii/downloads The way the page is worded, it really looks like the old ones won't work.
    – Tetsujin
    Commented May 3, 2015 at 15:57
  • Hi Tetsujin, thanks for the response. I have been trying to install the latest drivers, yes. M
    – Michael
    Commented May 14, 2015 at 21:18

1 Answer 1

1

I don't have any experience with the specific drivers, but here is how I would attack the problem.

I would get a USB drive with a Mac partition I can wipe - it should be 20 GB or so (10 might work as well) and I'd download a clean OS installer from the App Store and install a clean OS onto that test partition.

You can use startup disk preference pane to switch between OS and then don't restore any files to the test OS. Just make a test account and apply all upgrades recommended by Tascam (10.9.5 or whatever) and then install just the driver.

You'll then have a clean system to know if the issue is Tascam's to resolve and/or know you can try again with different OS levels if the issue is really a driver-OS compatibility issue.

1
  • Now that is what I call "clean" approach :)
    – Ruskes
    Commented May 3, 2015 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .