After upgrading to Lion, my NTFS shared folders are no longer accessible. I can see the shared folder, but when I try to enter from Windows 7 box it says Windows cannot access \path\to\usbsharedresource.

Even BOOTCAMP partition which was shared and working now inaccessible...

SMB is ON.

  • Can you provide more information? It's not clear what device the shared NTFS folders are on. – conorgriffin Jul 26 '11 at 19:59
  • @Griffo: on all devices containing NTFS partition. I tried built in HDD BOOTCAMP partition as well as external HDD formatted as NTFS. OSX native partitions are very well accessible. – Pablo Jul 26 '11 at 20:13
  • Please explain a bit more about what you are trying to do. Give a specific example. You are running OS X Lion, you have an external NTFS formatted drive, that you can access from Lion, are using file sharing from Lion in system preferences, via SMB, but can't access those shares from Windows 7 via the network? If that's not right, please clarify. – zevlag Jul 26 '11 at 20:57
  • @zevlag: BOOTCAMP is not external, it's internal. However, USB HDD is external. SMB option is on in OSX preferences. Generally your understanding is correct. – Pablo Jul 27 '11 at 5:19

Upgrading to Lion breaks SMB. Something to do with UUIDs or GUIDs I think.

Create a new user on the system, give that new user access privileges through the SMB share, and connect to the share using the new user name/password. Accounts that existed pre-Lion upgrade won't work due to this UUID problem.


MacFuse is broken in Lion. Try http://www.offthehill.org/articles/2010/12/31/macfuse-for-64-bit-snow-leopard.


A friend of mine had a similar problem. After upgrading from Snowleopard to Lion he could no longer access his Windows partition.

He bought and installed Tuxera NTFS for Mac (There is also a trial available).

For him it worked and he could again read and write his NTFS partition.

  • Are you sure he had problem accessing NTFS drive over network or locally? I don't have issue accessing it locally. – Pablo Aug 2 '11 at 19:10
  • From what I've gathered he could mount it in Lion but did only have read-access to it. Therefore he could not boot from it using VMWare or Bootcamp. After he installed the Tuxera software he could then again boot from it like he could when he still had Snow Leopard. – Besi Aug 3 '11 at 6:41
  • Definately not what I asked. – Pablo Aug 3 '11 at 8:17

Apple has changed the Samba's version that comes with Lion due to problems related to licenses and stuff.

Fortunately for you, I was having the same problem and I have found a solution for it :)

If you follow the instructions on the following link, you will be able to share your folders again.

Attention: It's better if you're comfortable with Terminal and a few commands.



Here is a good description how to enable NTFS read/write on Lion http://fernandoff.posterous.com/ntfs-write-support-on-osx-lion-with-ntfs-3g-f

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .