5

I want to connect my PS3 controller to my MBP 2015 however my MBP does not seem to detect that it is there, or at least I cannot view it in the menu.

Does anyone know how to solve this?

If it helps this is what I have done so far.

  • Plugged my ps3 controller into my MBP 2015 with the cable
  • Looked in the Bluetooth menu (cannot see it)
  • I have also tried pressing the 'PS' button while connecting the controller to my Mac. All this does is make the lights blink faster.

I need to connect my PS3 controller by Bluetooth and not USB because I want to sniff the Bluetooth packets so I can make a Python library to control my PS3 with my Raspberry PI.

2

According to the steps listed here, you have to connect it with a USB cable first, press the PS button until the blinking lights speed up, then disconnect the cable. The faster lights indicate it is trying to pair. Once the cable is disconnected, the Mac should request the pairing passcode which is 0000.

This pairing process should only be a one-time setup, and going forward you should be able to connect simply by turning the controller on.

Note that you may need to reset the DS3 before attempting to connect it to your Mac - to do so, use a paperclip to click the reset button, which is left of the L2 button.

DualShock 3 controller showing Reset button

(Image from Sony)

  • If I reset it will I be able to connect it back to the PS3 afterwards? If so how? – iProgram May 3 '15 at 22:10
  • Yes, by following the same procedure while it is attached to the PS3. – tubedogg May 3 '15 at 22:15
  • My Mac still doesn't detect the PS3 controller. Even tried resetting the controller. Any other suggestions? – iProgram May 5 '15 at 15:46
2

Apparently, Yosemite breaks the support for the PS3 controller. This can be easily seen when looking into /var/log/system.log. When connecting the PS3 controller via USB, you'll see something like:

Aug  8 09:08:19 somebody-macbookpro kernel[0]: [IOBluetoothHIDDriver][probe] Couldn't retrieve device properties
Aug  8 09:08:19 somebody-macbookpro.local blued[84]: addDeviceToHIDEmulationMode - unrecognized HID device; NOT storing the link keys to the module.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .