1

I have a 2009 Mac Pro (4,1) that has had the "unofficial" 5,1 firmware update applied (to enable additional CPU support), CPUs upgraded to dual 3.46 GHz 6-core Xeons and GPU replaced with an AMD Radeon R9 280x flashed for Mac. It's running Yosemite 10.10.3. The graphics card uses the AMD drivers that ship with OS X.

I am having graphical glitches - a couple of different ones, but this is the one that's bugging me the most right now. (Link is to a screen recording made with QuickTime Player.)

The system upgrades mentioned above happened in February, and I have only noticed this issue within the last month-ish, so I don't think they are related. I did notice this issue before upgrading OS X from 10.10.2 to .3, so I don't think that's related either.

It only appears to happen in Chrome, although oddly, one of the glitches that happens (not caught in the video, sadly) is a black rectangle appearing over the middle of the menu bar, outside of Chrome's window - but only when Chrome is in the foreground. Switching to any other application when that happens causes the black box to disappear instantly. Another manifestation places a gray rectangle over the middle of the tab bar. Clicking on a couple tabs usually makes it disappear, as does, again, switching applications.

I found what may be a related bug in the Chromium bug tracker, but I am not seeing the extensive corruption/glitches shown in the screenshot attached to the bug (maybe I'm lucky?!?), nor am I seeing any issues in webpages themselves, only the tab bar, address bar and bookmark bar. I did add comments on that bug though.

I was using Chrome beta (stable version + 1 basically) but have reverted to Chrome v42.0.2311.135 stable and am experiencing the same problems. I have disabled all extensions and Chrome hardware acceleration and the problem persists.

Any ideas?

  • idk the answer, sorry - but would it be worth sticking the old GPU back in & testing? Might eliminate the GPU as the issue. (At least it's a Pro, not an iMac - different degree of difficulty altogether;) – Tetsujin Apr 30 '15 at 6:45
  • @Tetsujin I'd have to figure out where I put it. :P But besides that, it didn't start then, and it's not system-wide. I forgot to mention I also tried disabling hardware acceleration in Chrome and that did not resolve it, so it shouldn't even really be trying to push the GPU that hard. – tubedogg Apr 30 '15 at 7:01
  • I wasn't really thinking in terms of the amount of work it was doing, just drivers vs 'not a real' card, compared to a 'real' card. I have been seeing not quite the same glitches, but I do sometimes get black patches in web pages, after quitting a full-screen app [of course now I want to force it to show you, it won't break;) Though my card is an 'official Apple one, it's still a retro-fit HD 5770; older than yours & in a Pro 3,1 so not really any direct comparison. I can't put my old one back to check, it died years ago. – Tetsujin Apr 30 '15 at 7:08
  • Le sigh...So I have been toying with switching to Firefox, both for this issue and cause Chrome has seemed ungodly slow at times lately. I just saw the issues described above in Firefox. >< I guess it probably is the graphics card. I don't understand why it's only affecting browsers though - I haven't seen this in any other application, and switching out of the applications resolves it instantly. – tubedogg Apr 30 '15 at 12:16
  • You have my sympathy - but if it's only a minor irritation, weigh it up against having a dual 6-core 3.46 5,1 with equivalent graphics ;-) – Tetsujin Apr 30 '15 at 12:31
1

After seeing it in Firefox too, I decided it must be hardware-related. To avoid having to open up the Mac and change out the graphics card (which required a bit of effort to get the new card in there in the first place, due to it not aligning precisely with the PCI slot opening in the back), I tried changing out the cord. (I recently switched from having it plugged in with a DVI output -> DVI cable -> DVI input on monitor to a Mini DisplayPort output -> MDP/VGA adapter -> VGA cable -> VGA input, and the cord has issues I guess.)

It seems to have resolved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .