0

Dragging text used to be instant. Now, especially after an application’s been open a few minutes, it takes forever from the time I press the mouse button on text until I can drag it. (If I try to drag it before the cursor changes form the text-insertion icon to an arrow, the text is deselected.) I’ve timed the delay a few times, and the longest one was about 35 seconds from mouse-down to cursor-change.

I started noticing this about six months ago. The only change to the system that I can think of that coincided even slightly was Yosemite. I’ve noticed it mostly in Scrivener, which is almost always where I drag text. But it also occurs in Calendar and Mail.

Closing the app and reopening it fixes it for a minute.

I’ve tried the Terminal command to eliminate the delay, and it seems to have no effect. (defaults write -g NSDragAndDropTextDelay -int 100) I’ve also tried the Tinderbox adjustment.

What could this be?

  • Could be that the app is paging to disk. I'd check Activity Monitor & see what's going on. – Tetsujin Apr 30 '15 at 6:36
-1

I had the same in Scrivener. Just don't use the 0.1 second. 0.2 and up solved my problem so far. I made the adjustments with TinkerTools http://www.bresink.com/osx/TinkerTool.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .