I'm trapped in a HDD nightmare with my MacBook Pro mid-2012.

I updated to Yosemite 10.10.3. A couple of days after the update, I was watching a movie on my TV screen via HDMI. In the middle of the movie I removed the HDMI cable from the MacBook Pro and everything freezes. I forced shut down (Note: My HDD was encrypted). After I forced shut down, I tried to turn on and the loading screen would never stop loading - like, 14 hours stuck with the progress bar. Since I have backups, I decided to access DU and format my HDD. I tried everything. For real. Every command line I could type on Terminal to format, repair, erase and/or partition. I read almost every issue-related questions on the forums and stack exchange groups for a week (even posted my issue here: Erasing and Partitioning Hard Drive from Internet Recovery).

So, I decided that it was a HDD failure and bought a new one.

I bought the Seagate 1TB SSHD Hybrid - ST1000LM014. Installed the new fresh disk and guess what? All those same problems again. I´m not able to restore from Time Machine because it doesn't recognize the disk in the restore page. But the disk is recognized in the DU. When I try to erase or partition the new SSHD, the same old errors: File system formatter failed. Yes, I tired GUID Partition Table, all of the security options, etc.

Please. Any light that you can throw at this issue, I'll be very grateful for. BTW, the new SSHD is recognized and the SMART Status says: Verified.

Any ideas on WTF is going on?

Thanks in advance!

MacBook Pro, i7, 8GB RAM, mid-2012, 13-inch.


2 Answers 2


So, after buying a new SSHD and SATA cable, spending 3 weeks reading and writing command lines on Terminal.... this is what fixed my problem, believe it or not: https://www.youtube.com/watch?v=Amg5w0rlwDo&spfreload=10

This video shows how an electric tape can isolate the sata cable and prevent it to touch the aluminium surface, which will cause you some problems.

I mean, seriously Apple? The design of the SATA cable path is so prone to failure....it's obvious!

  • 1
    Can you please summarize the video in your answer? Otherwise the answer becomes kind of useless as soon as the video disappears from YouTube.
    – nohillside
    Commented May 6, 2015 at 7:33

You might have blown the logic board…might have.

That unit uses an integrated I/O and video controller. I'd be afraid that pulling the video cable out may have produced a transient that damaged part of it. You might want to try putting one of the drives in an external case and see if it can work that way. Another possibility could be the SATA cable itself blew somehow (once again, transient).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .