0

I have recently migrated from a time machine backup of my previous mac. I have three different accounts on both my macs and two of these seem to work well. However, when I log in to the third account, I have some problems, especially on the new mac.

I have changed the password for all three users using the dialogue in system preferences.

Every time I log in, I see a screen that asks me to change my keychain password, or create a new keychain. When I choose to change my password, no input seems to be valid. When I create a new keychain, that does not seem to help either.

After choosing either continue logging in or choosing to create a new keychain, my mac will then ask me to log in with my apple id, which I can also decline.

If I continue past the apple id dialogue, my mac tells me: "Setting Up Your Mac..." which is pretty scary, considering it is already "Set up". Fortunately so far it has not wiped my HD.

It then logs me in into my user account and most of the time I get a lot of messages telling me that this and that process wants to access my login keychain.

I have tried deleting my keychain folder located at ~/Library/Keychains, as well as changing my password for the different keychains and checking the synchronise my keychain my user account checkbox under the preferences of the keychain utility. I have also tried to use the "Reset My Default Keychain" button. Two of these strategies are listed here. Unfortunately none of these seem to work.

Sometimes when I try to change the keychain password I find that I have to use my old password, sometimes the new one, and sometimes no input appears to get accepted (the last case happens when I try to change it from the dialogue that pops up when I try to log in).

On my previous mac I was also experiencing problems with this account. In particular it seems that any system preferences that I modified for would only last for one session, and would be forgotten when restarting my mac. One example is the hiding of the dock and also on my new mac osx forgets that I want to hide the dock.

Question: Does anybody know what is causing all this?


Strongly related: How do I delete or fix my Keychain after changing my password?

  • I have also tried repairing disk permissions – Matheor Apr 29 '15 at 18:26
  • Also one time my user account failed to load at all. – Matheor Apr 29 '15 at 18:28
1

There might be a problem with the users home folder permissions.

Repairing Disk Permissions in Disk Utility, will only affect things outside your Home folder, though.

There is a home folder reset routine if you boot into Recovery (cmd+r).

Once booted, Open Terminal from the Utilities menu.

Type resetpassword and hit return. (no worry you will NOT be resetting the password)

Select your hard disk, then the user.

Click the Reset Home Folder Permissions and ACLs button.

Quit the utility and restart.

  • Thank you for your answer. Unfortunately, bash tells me: -bash: resetpassword: command not found. My permissions on my user folder itself seem to be ok, they are: ls -led ~ gives drwxrwx---@ 26 myusername staff 884 Apr 24 14:57. Of course maybe some subdirectory like ~/Library may still have some permission problems (I will check this one now). – Matheor Apr 29 '15 at 23:08
  • that is strange? the resetpassword should have worked! what osx is it? – Ruskes Apr 29 '15 at 23:25
  • It is Yosemite, OSX 10.10.3 – Matheor Apr 29 '15 at 23:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .