0

I am using a PC keyboard on my Mac. Today, it stopped recognizing the Command and Option keys.

This likely happened because I experimented with Karabiner and Yosemite Modifier Keys yesterday.

I have tried:

  • Resetting modifier keys to defaults.
  • Checking private.xml through Karabiner (blank).
  • Undoing my settings on Karabiner.
  • Uninstalling Karabiner entirely.
  • Restarting OS X.

None of these things have worked. Keyboard Viewer is not registering key presses on Cmd (Windows key) or Option (Alt). Any ideas?

1

I opened "Keyboard Preferences" and clicked on the Modifier keys. Clicked on "Restore to defaults". And the modified keys started working again. After that I switched the modifier keys back to my preferred set. And things are still working. Feel quite good. It saved me an avoidable reboot.

I am in such a similar issue often. The problem used to get fixed after restart (probably will also work, after logout/login -- did not check). Today it happened again. I tried the defaults method above and it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .