I tried everything in here didn't work. I am using a 13" macbookpro retina, latest OS.

Stuff I did that might have cause this:

  • I updated 3 apps 1 of them was Xcode, the other was something about OSX, the third I can't remember.
  • I installed Cocoapods but never used it.
  • Did some tutorials and learned a little bash commands, nothing extreme that should have caused this.

After these actions I used the mac to write software, browser internet, watch videos, I used it for half a day and nothing weird happened. I closed the screen and reopened in an hour and had this problem.

Right now I am connected from the internet recovery. I see this screen:

enter image description here

  • I cannot restore from time machine backup, cause I have none
  • I cannot reinstall OS X cause it doesn't see my SSD. "Select the disk where you want to install OS X, under it nothing"
  • Get help online isn't very helpful
  • In disk utility:

Macintosh Hd, Disk Status: Offline Capacity: 120GB, Available: 120GB, Used: 335MB (Weird at least 100GB was used and I am pretty sure I didn't format it by accident)

I click "Verify Disk": The partition map needs to be repaired because there's a problem with the EFI system partition's file system.

I click "Repair Disk": Couldn't repair the partition map because a new EFI system partition couldn't be created.

Also tried this: What does "EFI system partition couldn't be created" mean?

  • I have seen a few posts where they recommend me to backup the system and then reinstall the OS. I cannot backup and I cannot reinstall.

What am I supposed to do? My hands seem to be tied..

  • 1
    I suspect you have a hardware problem -a hard disk failure
    – mmmmmm
    Apr 28, 2015 at 22:04
  • Do you have the EFI partition or not. (it is about 300Meg in size.)
    – Ruskes
    Apr 28, 2015 at 23:58
  • did you run the fsck from terminal to try to fix it. /sbin/fsck -fy
    – Ruskes
    Apr 29, 2015 at 0:01
  • It has been my experience that if you lose your EFI partition the Disk Utility application will become unreliable, but the commands entered using the Terminal applicaton will still work. It would be interesting to see if you could use the dd command to retrieve to a flash drive the 4 sectors containing GPT header, beginning of GPT table, backup GPT header and backup of beginning of GPT table. You could then use the xxd command to dump the contains to printable hex characters for me to read. I would give me (and others) an idea if the basic partition data structures are still intact. Apr 29, 2015 at 13:22

1 Answer 1


If you have a backup, format the Mac's drive, taking care to protect the backup. If you don't have a backup, try some tools like DiskWarrior or TechTool on the Mac's drive. If those don't help, you'll probably have to format and lose your data.

If you can't format the drive, it will need to be replaced.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .