I have a Seagate FreeAgent Go drive with the optional docking station. I use it to keep files that I don't access on a regular basis and as a place to do "quick backups" of things like my Paperless library or my Lightroom Catalog. This morning, I saw a message on my desktop (I didn't shut down) that I failed to eject it properly.

Now it will not mount.

If I run

diskutil list

it dosen't show up at all. It's not there. Period.

However, in system profiler, it shows up under the USB, but not under the storage.

USB- FreeAgent Failed

Ok. So I thought my drive is dying. If I plug it into another computer, it works perfectly. In fact, I plugged it into a Surface RT of all things and I was able to read and write with no problem. It also works on another Mac (MBP 10.10.3) I go back to my iMac with 10.10.3 and nothing—it's like it dosen't exist.

Here's the kicker: I have another FreeAgent Go drive, exact same model and size as the one that dosen't work, and if I plug it in to the exact same dock, it works.

Different drive, what it's supposed to look like

I have checked my console logs and the only thing that comes up when plug in the failed drive is the error message

USBMSC Identifier (non-unique): 0x00000000 0xbc2 0x2100 0x0, 2

I have removed all USB drives, did a warm reboot, a cold reboot and even a reboot in safe mode: no joy.

Everything I have searched for has something about not being able to boot and the fix is repairing the disk via recovery console. That's not my issue. I can boot just fine. I just can't read this USB HDD.

Anyone else run into this?

  • It may be a no-brainer, but since you did not mention it (or if, I overlooked it), I got to ask: Did you properly restart all affected equipment in the meantime (especially the computer)?
    – Phoenix
    Apr 28, 2015 at 21:10
  • Yes. I removed all USB devices and I did a restart, and cold restart and a restart in safe mode. I should have mentioned it.
    – Allan
    Apr 28, 2015 at 22:40
  • Is there a difference when booting from Recovery HD, then use Disk Utility there. Does it show up there? If it DOES show up, there may be something wrong with your user environment or your current installation. If it does NOT show up there either, you may want to reset the SMC (PRAM can also be tried, but I'm not convinced resetting the PRAM will fix the issue).
    – Phoenix
    Apr 28, 2015 at 23:22
  • When booting from recovery console, it is found. Something in my configuration has changed but I have no idea what.
    – Allan
    Apr 29, 2015 at 2:23
  • What about a new/different user account in your current installation of Mac OS X. Would it show up there as well (try to log in first and then attach the drive)? Reason is that Mac OS X has two sets of configuration settings: user-specific ones and system-wide ones. If a new or different existing user is working, it will be in your user environment only. Otherwise, Mac OS X itself took a hit.
    – Phoenix
    Apr 29, 2015 at 5:35

3 Answers 3


I just started having this exact same problem with my FreeAgent Go drive which has always been working perfectly. Like the original poster I cannot see the drive in Disk Utility but it does show up in System Information. After a little more digging I found that the OS is trying to repair the volume BEFORE letting Disk Utility see it via an process named "fsck_hfs". When I force quit that process in Activity Monitor (it's owned by Root so you'll need to give it permission), the volume immediately appeared in Disk Utility. I'm running a repair on it now - fingers crossed. My guess is that since this is formatted HFS+ Journaled something about the journal consistency got flagged and the OS is attempting to repair it from the journal. I'm shocked that they hide it from Disk Utility while it's happening though - much better would have been to display the drive there without mounting the partition, and display a message that this is being done. Oh well at least I can see why Windows would mount it but OSX won't now (any OSX machine would start performing the same repair process).

  • Thank you. You saved my hair, my hard disk and sanity. I can't thank you enough!!
    – nikjohn
    Mar 29, 2017 at 15:52
  • 1
    Thank you. Solved for me as well. In my case, the problem began when I had been running a "first aid" check on my usb drive (my time machine backup drive) and I tried to stop the process since it was taking more than a few hours. At that point, the drive stopped showing up, but I did notice the fsck_hfs process in the activity monitor. When I force-quitting fsck_hfs, the drive immediately appeared on my desktop with a popup message saying that SierraOS could not finish fixing the drive and "backup failed". Now I can see the drive again in disk utility, running first-aid from there. May 29, 2017 at 16:05
  • To note: When the drive had been corrupted, restarting my MacBook would show a gray screen at 100% brightness for 10 minutes, and then it would boot up normally. Unplugging the usb drive and restarting the computer, the mac starts normally and only takes 30 seconds to boot up. May 29, 2017 at 16:10
  • If the disk was formatted for windows, it will show up as fsck_exfat or something similar. Sep 25, 2017 at 15:19
  • Thank you so much. Worthy reading: apple.stackexchange.com/questions/230698/…
    – Roberto
    Mar 19, 2019 at 8:24

The problem was VirtualBox. Specifically, the Windows 7 VM instance I had running was "grabbing" the device for itself. So, it unmounted it from OS X and passed the USB port to the VM. It was doing it automatically so I couldn't see anything.

To fix, you uncheck the device next to the USB filter.

VirtualBox USB Filter

The filter automatically connects a USB device to the VM instance so you don't have to do it manually (like my Zune).

Now, this is where it becomes confusing...I have 4 VMs running and all are set to autoboot when the host (OS X) starts. I haven't changed the settings in any of those VMs in at least 2 months and the the Windows 7 machine in at least a year. I don't need to; as everything was working. Now, way back when I was configuring them, I did attach the USB drive to the VM so I could install programs, backup some files etc. But when I was done, they were disabled. Somehow, they got re-enabled.

  • Glad you found out.... however, I don't have VirtualBox on my Mac, but I have the same exact issue as you... Dec 30, 2016 at 19:28
  • @JakeToronto - The best thing to do is ask a new question so more people can see it. Reference this question and what your console output is when you plug in the device (if any). More than likely I will also chime in with some suggstions
    – Allan
    Dec 30, 2016 at 20:17

For my case:

  • The device doesn't show in Disk Utility
  • It does show in System Information under USB
  • It works in other computers
  • Other USB sticks work in this computer
  • Changing USB ports makes no difference

I just rebooted the system, then it's mounted and working correctly.

  • The OP already said a reboot didn't fix the issue & also provided the actual cause in an answer.
    – Tetsujin
    Oct 11, 2015 at 9:25
  • 8
    i mentioned above "for my case" and for your reference.
    – codeye
    Oct 18, 2015 at 9:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .