20

I have seen people say to click get info then do something with the 'open with' but when I go to get info there is NO open with option, no options to change at all. I cannot drag the files into VLC like I could before the upgrade either. Please help me out! I am not real tech savvy, but I can do basics and follow instructions. Thanks.

  • Delete VLC and install it again. Seems to be an error in VLC application. Maybe consider to downgrade (VLC). – JW_ Apr 28 '15 at 1:32
32

Right click on any movie file you have.

Get Info

At the bottom of that window you will see the current app used to open it.

Change to VLC and use the "Change all"

enter image description here enter image description here

You need to repeat that for all movie files that have different extension.

Normally you would have .fvl, the .mov, and maybe some other formats.

  • There is NO current app listed, the bottom says Movie, and there is no option to change it. what next? – Sara Apr 28 '15 at 1:35
  • Do you have any movies at all ? – Ruskes Apr 28 '15 at 1:36
  • I am trying to play a video I took with my iPhone 6...that is what I am right clicking on...I guess that is a movie? I have other movie files that are no problem to play on VLC. These videos that are problems are in my iPhoto, would that make a difference? – Sara Apr 28 '15 at 1:37
  • ok, what does it show as what app is playing it (in the get info window) – Ruskes Apr 28 '15 at 1:39
  • here is what the get info window shows: img #, date and time taken,iphone6, no lens info, 7620x1280, 30.1MB, H.264, 30.01fps, 00:32, add description, Movie (movie is in a little blue box). no app that I see... – Sara Apr 28 '15 at 1:40
1

I just tested a m4v file with VLC Version 2.2.1 and it works fine. (Not sure what type of media files you are trying to open) So here is what I did:

Right click or ctrl+click on the media file Open with > VLC VLC Open with from Finder

The file opened just fine. To open ALL files by that type: Use the Get Info option. (in the picture) From there you can select Change All

Change all to use VLC with all files of this type.

I hope this is useful to you in solving your issue.

  • Try "View In Finder" to see if that helps. As opposed to info in Photos app. – bjbk Apr 28 '15 at 2:01
  • Thank you! I just had to understand that I cannot open the files while in iPhoto with VLC anymore, I have to go through finder. – Sara Apr 29 '15 at 12:22
1

Choose a file in your Finder, left click on :

enter image description here

Choose VLC app and check the 'always open with' box

enter image description here

  • 1
    That only works for the current file, not all files with that file type. – i-CONICA Apr 17 '16 at 0:50
  • VLC is not appStore trusted application, so the mac prevents to make it as a default application for video. – AmerllicA Sep 11 '18 at 14:21

You must log in to answer this question.

protected by Community Oct 1 '16 at 21:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .