4

My wife's 16gb iP5 is not optimizing iCPL she is now out of space. What do I need to do to fix this? I've read that if I turn off iCPL on her phone and then delete all the pictures in her photos app including Recently deleted then restart her phone and turn iCPL again it will revert to optimizing again. Is this an acceptable method for fixing this what I consider to be a still in beta Apple app. Very disappointing.

  • 1
    With a 16GB model (of which about 3GB is used by the system), it is very easy to fill it up regardless of whether photos are present. How many photos (and videos) are in iCloud Photo Library? Even with the "optimized" setting turned on, if there are a lot of photos, it could still take several GB of space. I have about 10,000 photos in iCloud Photo Library and on my iPhone 6 it takes about 3GB, even with "optimized" turned on. – tubedogg Apr 28 '15 at 6:10
  • 1
    We have 25500 photos, my iP6/128Gb uses 7Gb for photos. I was able to regain 2Gb on her phone after my method I offered in my answer. She really needs a new phone but doesn't want one. I'm not sure if Apple's method for optimizing is going to work reliably. We will have to wait and see. As an aside I would like Apple to offer an option to delete a photo on an iOS device without it being deleted everywhere. There should be a designated device such as a computer that is the master for iCPL and all other devices have the option to delete photos, – Todd Apr 28 '15 at 11:15
  • meaning they are still in iCPL but revert to an optimized version when you delete it off your device. – Todd Apr 28 '15 at 11:15
3

I turned iCPL, Photo Stream and iCloud Photo Sharing off in Settings/General/Photos & Camera, rebooted her phone and then turned on all that I had turned off. The phone then showed a spinning gear for about 5 minutes saying "Turning On" and after that I went to Settings/General/Usage/Manage Storage, and saw that her phone regained 2Gb of storage back from only having 388Mb available. I did not have to delete all of her photos after I turned iCPL off.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .