For a couple days now, whenever I try to download an app from the App Store on my iPhone 5s with iOS 8.3, it brings up the 'use existing Apple ID' or 'create new one' window.

When I select the existing one and fill in my account information it closes the pop up window and starts to download the app (indicated by the circle starting to turn) but after one second it goes right back to the 'get' button.

When I try to download it again it all goes to square one. İt has been driving me nuts! İts like a vicious circle!

  • To begin with, before changing settings and such - check app store status apple.com/support/systemstatus Commented Oct 15, 2015 at 6:08
  • 1
    Another thing no one has mentioned - This happens when you are signed in to the device with a Sandbox account. To resolve the issue sign out of the sandbox account in Settings and sign in with a regular account. (I don't have enough rep to post an answer so I'm writing this as a comment here) Commented Apr 17, 2018 at 12:46

12 Answers 12


From the Apple help site at: https://support.apple.com/en-us/HT201400 it recommended

Make sure that your date, time, and time zone are correct. Tap Settings > General > Date & Time.

My settings were correct. However I turned off the automatic date/time/timezone feature to make the date and time zone setting be manual.

Voila, I could connect to the iTunes/App store. I had turned my phone off and on several times. I really wanted to avoid doing a reset. So I've escaped it for now.


Go to Settings> iTunes & AppStore > Password Settings > slide the "Require Password" switch. This worked for me for free apps.

  • I tried this, but now I just get "Cannot connect to the iTunes Store".
    – Jowie
    Commented Oct 15, 2015 at 6:56

Go to your setting, change your language to some other than your default one, let it respring and after that change back to your default language. After that it should be ok again

  • Can you be more specific? Which settings page are you taking about, General > Language & Region? Which part did you change? iPhone language or Region Formats?
    – Jowie
    Commented Oct 15, 2015 at 7:00

Whenever there is strange behaviour that doesn't seem to resolve itself, this tends to indicate that the device is hung up with respect to the sequence of steps that it needs to complete.

To force the device to take a fresh start at doing the task, you should restart the device.

  • 1
    That was one of the first things that i did but it didnt make a difference after the restart. Also i signed out from the app store account information part in the settings and signed in again but it was the same. I do have enough space that doesnt seem to be an problem either.
    – janeeyre
    Commented Apr 28, 2015 at 15:58

A solution to many strange iOS problems is to back up and restore the device. I saw this issue on an iPad before, and could find no solution besides restoring it.


I'm having the same issue and I'm pretty sure it started with the last iOS update. One workaround I've found has been to purchase the app from iTunes on my computer. Then, go to the Updates tab in the App Store on your phone and click on Purchased items at the top. The app will be available there for download.

The only issue I'm having, and cannot resolve, is that I cannot make any in-app purchases and that's not something that can be done on a computer. Any thoughts on how to solve that?


Try changing the Language setting on your phone, then change it back again to your normal language.

Settings > General > Language & Region > iPhone Language

I had a similar problem and after trying various things, the language swap fixed it.

For reference, other possible fixes for problems like this (in rough order of how annoying they are to do):

  • Kill the App Store:
    Double tap the Home button, then swipe up on the App Store app
  • Restart the phone:
    Hold Home and Power buttons for about 5 seconds until phone reboots and Apple logo appears
  • Log out of App store and then sign back in:
    Settings > iTunes & App Store > AppleID, then Sign Out
  • Reset All Settings:
    Settings > General > Reset > Reset All Settings
    NOTE: This will delete lots of settings but NOT your data.

Look for what has recently changed on your device. I realized I have installed DeDirect and the IAPFree standalone plugin in Cydia (there were updates of the latter in Cydia). I removed DeDirect first but didn't fix the issue. After remiving the IAPFree stuff all went back to normal and AppStore download worked again. Have now reinstalled just the IAPFree standalone plugin and will wait for the next update to come through the Appstore. As a general rule, always think of what has changed since last time it worked. Feedback and let us know if that fixed it for you. Thanks


If you are trying to download a free item from the App Store this WILL help.

Settings > iTunes and App Store > Password settings > go from 'always require' to 'require after 15 minutes' > switch the 'require password' selection from on to off .


Try changing the Language setting on your phone, then change it back again to your normal language.

Settings > General > Language & Region > iPhone Language This work me iPhone5 IOS8.3


I had a similar problem. Tapping the "Get" button would only cause the button to disappear and reappear silently. After I signed out of the App Store and tried to sign back in, I would get an alert that simply said "Could Not Sign In".

After a bit of troubleshooting, I realized that my home network was blocking access to init.itunes.apple.com. Unblocking this fixed the problem.

In other words, make sure that you're not behind a firewall or proxy that may be blocking certain connections.


If you are having trouble downloading or updating apps from the App Store, try using your Touch ID instead of your Apple password. Settings>Touch ID & Passcode then turn on the iTunes & App Store option. Cheers!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .