3

More or less from iOS 8.2 update I suffer a little, but very annoying, trouble in Safari.

I open Safari, I type in the search bar what I need (web page or something to search on Google) then I've to wait from 5 to 20 seconds to launch the command. Until the table under the search bar is empty, pressing search button doesn't makes happen nothing!

Am I the only one with this issue? Is there a way to solve?

1

I had the exact same problem! I got the following solution, courtesy of a call to Apple.

  1. Go to Settings > Safari
  2. Select "Clear History and Website Data" (note: this will wipe your history on your phone and any devices that sync their Safari data with your phone's over iCloud.
  3. Change the Block Cookies setting to Always Block.
  4. Close Safari from the app switcher.
  5. Change the Block Cookies setting back to Allow from Websites I Visit.
  6. Enjoy your non-laggy Safari!
  • Thank you! I didn't thought on history but it's true, searching through an year of history could be a long operation! Unluckly I can't do that because I don't wanna clear my history on Mac so I got to keep my lags! ...do you know how to reduce my history period of time? I remember that was possible but I don't remember how... – Matte.Car Apr 27 '15 at 14:30
  • All my ideas now, no guarantees about anything, but: You could try switching off iCloud Safari on your phone before doing the operation. – user24601 Apr 27 '15 at 15:28
  • 1
    Yes it works! Is incredible that, without doing the steps 3, 4 and 5, trouble doesn't solve!! – Matte.Car Apr 28 '15 at 7:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .