I use OS X Yosemite 10.10.2 and have VMware Fusion 7.1.1 where Ubuntu 14.04 has been installed. Moreover, I have installed VMware tools patches.

Copy and paste between Mac and Ubuntu using keyboard shortcuts (Cmd+C then Cmd+V) worked fine before. I don't know if it is because of the recent upgrade from VMware Fusion 6.x to 7.1.1 or the installation of the VMware tools patches, copy and paste does not work any more. Here are some screenshots of the settings:

enter image description here enter image description here

Could anyone help?

  • It's not really about the shortcut. I'm not sure about VMware, I only know about Parallels - there should be an option somewhere like "share clipboard" – Kevin Grabher Apr 27 '15 at 6:42

Look under the settings for that particular VM, not the "App Preferences." Each specific VM has it's own settings, and there are granular controls for Host <--> Guest sharing.

I only have Parallels, or I would post screenshots, but it is quite similar, from what I remember of previous VMWare Fusion versions that I used at my old job.

In the "Launch" screen, there should be a gear or some settings button for that specific VM.

Here it is in Parallels, FWIW.

Settings button

Settings Pane

After a test install of Ubuntu 14.04.2 LTS in VMware 7.1.1/Mac OS X 10.9.5, then using the following (shortened) guide to download the latest VMware Tools and applying the patches, copy & paste with keyboard shortcuts from the Linux guest (ctrl+c/v) to the Mac host (cmd+c/v) and the opposite direction just works.

1. Checkout the repository:

    $ git clone https://github.com/rasa/vmware-tools-patches.git

2. Download the latest version of VMware Tools into
   the vmware-tools-patches folder which should reside in your user folder.

    $ cd vmware-tools-patches
    $ ./download-tools.sh 7.1.1

3. Untar the tarball, and apply the patches:

    $ cd vmware-tools-patches
    $ ./untar-and-patch.sh
4. Run the vmware-install.pl installer to install VMware Tools:

    $ ./compile.sh

My VM-settings look like this:

enter image description here

enter image description here

Inside the Ubuntu VM I use the "English (Macintosh)" or "German (Macintosh)" keyboard layout.

My advice: trash the folder "vmware-tools-folders" in your user folder (or wherever you have downloaded it previously), download the patches, download the VMware Tools, apply the patches and install the tools like described in the above guide. You don't have to/mustn't reinstall/install the VMware Tools from the VMware Fusion menubar -> Virtual Machine -> Reinstall VMware Tools following the above guide.

  • Thank you for the test... I followed your guilde to re-install the VMWare Tools, it still does not work... It is very odd... – SoftTimur May 1 '15 at 0:01

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.