I can’t find the .plist file for TextEdit, Preview. I’ve looked into /Library/Preferences, ~/Library/Preferences, and ~/Library/Containers. I have tried opening the app and changing the preferences and still it doesn’t create them.

I run the following command in Terminal to find it:

mdfind -name (osascript -e 'id of app "Preview"').plist -onlyin ~/Library/Preferences -onlyin /Library/Preferences -onlyin ~/Library/Containers/

I also looked myself and they weren’t there. Any reason this is happening? Odd this is I can still read the defaults with defaults read -app Preview in the Terminal. So where is that coming from, is there another place it’s stored at.




~/Library/Containers does not seem to be indexed, at least on my system, so mdfind didn't find them. That said, I have a copy of my system on another hard drive, which IS fully indexed, and it listed some files there that started me poking around in that folder on my OS drive.


For TextEdit :

$ ls ~/Library/Preferences/ | grep Text

For Preview :

$ ls ~/Library/Preferences/ | grep Preview
  • That’s not the preferences, that’s something else. The files the app has access to and created bookmarks? Anyways, it’s different than what you get when you do defaults read -app Preview or defaults read com.apple.Preview. Where is the file it reads from in either of those commands?
    – user14492
    Apr 27 '15 at 2:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .