16

after you paste a URL in Notes, is there a way to have the hyperlink(?) turned off so you don't click it by accident and be taken to the webpage? It'd be nice if the URL can be there just as pure text.

2
  • Wow this is annoying. Links even appear in the middle of new sentences I just typed after I hit "Done" editing. There must have been something there before?? They some places they build up and seem to take over the text more on each edit. I guess I'd have to start a new note to get rid of that.
    – mikato
    Jun 27 '17 at 14:20
  • Even as annoying - when it make a phone number link because the number of digits you typed in (say a part number or something) happens to match the US phone stanard of 3+3+4 A longpress on the link should bring up a 'delete link' option. But then this is apple.
    – user68743
    Dec 13 '17 at 0:03

11 Answers 11

10

At least for iOS 11.2 the following works:

  1. Select the text you want to unlink (or position the cursor “inside” it or directly before or after it)

  2. Switch to the format keyboard (not the format tool-tip):

    format keyboard

  3. Click “Body” twice on format keyboard:

    format keyboard

5
  • 1
    This still works in iOS 12. The “format keyboard” is the Aa you can see right above the keyboard. Dec 12 '18 at 18:31
  • 1
    This worked perfectly for me in iOS 12.
    – fsb
    Feb 21 '19 at 0:35
  • This hidden feature was well hidden.
    – Jonny
    Aug 15 '19 at 1:24
  • Works for iOS 13 as well. When you paste a link to notes, it becomes tapable even when editing. Selecting this link and changing its style to Body (with two taps on Body) transforms it back to regular text. And it’s still tappable in view mode.
    – zh.
    Oct 12 '19 at 12:00
  • 2021/ipados 14.7: the select and double tap works -- until you re-open the note when it changes to an active link again, durn it! The re-opening step seems to be when changes are actually 'committed' and saved, and the program is apparently coded to scan the body of text (rich-text style?) and make link type text into links. That appears to be how it is intended to work, and I don't know of an option to turn that off for a single link text.... Jul 29 at 13:06
6

Go to Edit then Substitutions and uncheck Smart Links

3
  • 1
    The question is asking about "Notes in iOS"
    – grg
    Feb 3 '16 at 15:29
  • 1
    I know the question asked about iOS, but I was trying to find the answer for Mac and found this, and it was just what I was looking for! Thanks!
    – Doktor J
    Sep 30 '16 at 19:29
  • 1
    perfect , this is is exactly what I was looking for
    – Dinis Cruz
    Dec 2 '20 at 6:24
0

Unfortunately there is not. There are many posts with a google search that reveal the same answer. If you have Pages for the iPad you can remove the links but not on the simple notes app from Apple.

0

use a comma for times (5,15 pm) and dates (10,17,2015), instead of colon (5:15 pm) and slash (10/17/2015) when writing in notes.

1
  • The original question was asking about URLs, specifically. Though this workaround works for dates and times, it doesn't work for URLs.
    – Tuesday
    Oct 18 '15 at 1:46
0

It's definitely a frustrating issue. What I do is, after pasting the link into Notes, I add either text or punctuation to the end of the link, with no space in between. Typing a few periods is the easiest for me. That changes .html into .html..., which breaks its format. Notes no longer sees it as a viable address, so it will just be text. If you change your mind, or need to use it to get to the webpage, just erase those periods, and it will become a live link.

0

To remove hyperlinks on Apple Notes, go to after the hyperlink (if you have more text after the link), but make sure that the cursor is touching the non-highlighted word. You should now be able to delete the link and re-type it after to make it non-highlighted.

If you only have the hyperlink and no other text, you must memorise it, delete the note, go to a new note and re-write the hyperlink there. If this doesn't work, keep repeating the process until it works.

If you are on Pages, highlight the link, and there should be an option to delete the link.

0

This is probably a recently added function but just in case anyone stumbles on this answer like I did trying to figure it out.

In Apple Notes running in El Capitan (10.11.5) for me, you can right-click on the link and in the menu there is the option to delete the link.

1
  • The question was about iOS, not OSX..
    – wickywills
    Dec 2 '19 at 8:13
-1

To remove the hyperlinks, cut the text from the Note and paste into Word for Mac; a small box will appear at the end of the text asking whether you wish to keep the original's formatting, adopt the formatting of the Word doc, or whether you want to keep "text only." Chose text only. The hyperlinks are transformed into simple text. Cut and paste this back into your Note. Hope this helps.

-1

I just cut and paste in to a new "Mail" composition, cut that and repaste, clunky but the only way I've found that strips all formatting.

-1

Simply edit the text to include periods. Whenever I type in an address or phone number in Notes and do not it become a hyperlink, I simply add periods. Ex.

333.-.333.-.1234.

Mr. Green jeans. 3333. Green Lane. Garden City. WI. 11111.-.1111

-2

Highlight offender, Right Click > Substitutions > Uncheck Smart Copy and Paste.

1
  • The question is looking for a solution on iOS, not macOS.
    – grg
    Mar 10 '18 at 11:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .